Firefox Crash @ js::SweepAtomState

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
10 months ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

5 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
Seen while reviewing crash stats. https://crash-stats.mozilla.com/report/list?signature=js_SweepAtomState%28JSContext*%29 links to the reports which span all versions.





https://crash-stats.mozilla.com/report/index/b26b7203-cc37-4325-acbc-d88232110527

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js_SweepAtomState 	js/src/jsatom.cpp:451
1 	mozjs.dll 	MarkAndSweep 	js/src/jsgc.cpp:2260
2 	mozjs.dll 	GCUntilDone 	js/src/jsgc.cpp:2555
3 	mozjs.dll 	JS_GC 	js/src/jsapi.cpp:2665
4 	xul.dll 	nsXPConnect::Collect 	js/src/xpconnect/src/nsXPConnect.cpp:405
5 	xul.dll 	nsXPConnect::GarbageCollect 	js/src/xpconnect/src/nsXPConnect.cpp:413
6 	xul.dll 	GCTimerFired 	dom/base/nsJSEnvironment.cpp:3300
7 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:424
8 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:520
9 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
10 	xul.dll 	TimerThread::RemoveTimer 	xpcom/threads/TimerThread.cpp:417
11 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
12 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
13 	mozcrt19.dll 	_VEC_memzero 	
14 	xul.dll 	xul.dll@0x36f13f 	
15 	firefox.exe 	firefox.exe@0x1bb7 	
16 	kernel32.dll 	GetCodePageFileInfo 	
17 	kernel32.dll 	BaseProcessStart 	
18 	firefox.exe 	firefox.exe@0x186f 

Addon correlations:

95% (21/22) vs.  77% (15092/19580) testpilot@labs.mozilla.com (Mozilla Labs - Test Pilot, https://addons.mozilla.org/addon/13661)
18% (4/22) vs.   0% (37/19580) {b4efb02b-cd4a-44b9-b5d9-aa486cdffab6}
18% (4/22) vs.   0% (95/19580) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}
18% (4/22) vs.   1% (204/19580) {EEE6C361-6118-11DC-9C72-001320C79847}
18% (4/22) vs.   3% (684/19580) engine@conduit.com
100% (22/22) vs.  90% (17684/19580) {972ce4c6-7e08-4474-a285-3208198ce6fd} (Default, https://addons.mozilla.org/addon/8150)
14% (3/22) vs.   6% (1203/19580) {b9db16a4-6edc-47ec-a1f4-b86292ed211d} (Video DownloadHelper, https://addons.mozilla.org/addon/3006)
14% (3/22) vs.   8% (1482/19580) {CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
(Assignee)

Updated

7 years ago
Crash Signature: [@ js_SweepAtomState(JSContext*) ]

Comment 2

6 years ago
It's #51 top browser crasher in 12.0, #33 in 13.0b7.
Crash Signature: [@ js_SweepAtomState(JSContext*) ] → [@ js_SweepAtomState(JSContext*)] [@ js_SweepAtomState(JSRuntime*)] [@ js_SweepAtomState]
OS: Windows XP → All
Hardware: x86 → All
Summary: Firefox Crash [@ js_SweepAtomState(JSContext*) ] → Firefox Crash @ js_SweepAtomState

Updated

6 years ago
Crash Signature: [@ js_SweepAtomState(JSContext*)] [@ js_SweepAtomState(JSRuntime*)] [@ js_SweepAtomState] → [@ js_SweepAtomState(JSContext*)] [@ js_SweepAtomState(JSRuntime*)] [@ js_SweepAtomState] [@ js::SweepAtomState(JSRuntime*)]
Summary: Firefox Crash @ js_SweepAtomState → Firefox Crash @ js::SweepAtomState

Updated

6 years ago
Duplicate of this bug: 773822
(Assignee)

Updated

4 years ago
Assignee: general → nobody

Updated

2 years ago
Crash Signature: [@ js_SweepAtomState(JSContext*)] [@ js_SweepAtomState(JSRuntime*)] [@ js_SweepAtomState] [@ js::SweepAtomState(JSRuntime*)] → [@ js_SweepAtomState(JSContext*)] [@ js_SweepAtomState(JSRuntime*)] [@ js_SweepAtomState] [@ js::SweepAtomState(JSRuntime*)] [@ js::SweepAtomState]
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) in Firefox (except some obsolete Fx <18).
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.