Print job fails to print full images

RESOLVED WORKSFORME

Status

()

Core
Print Preview
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Nick, Unassigned)

Tracking

({testcase-wanted})

Trunk
x86
Windows XP
testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Trying to print off the article at this site http://live.gnome.org/GnomeShell/CheatSheet always results in some of the images being chopped off prematurely on the right margin. 



Reproducible: Always

Steps to Reproduce:
1. navigate to http://live.gnome.org/GnomeShell/CheatSheet
2. select Firefox button > print preview > Landscape setting
3. note how right margin of image on page 8 and page 11 is cut off prematurely

Actual Results:  
right side of image is not shown (it is cut off prematurely)

Expected Results:  
entire image will be shown/printed. The image will be shrunk to fit the landscaped page if necessary.

I'm filing this as a bug report because printing the article in Landscape in Google Chrome results in the whole image being shown/printed. So it is possible to achieve.
Seeing this on Trunk too.
How about Browsers other than Chrome (since they use a PDF-Preview for Printing)?
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
The problem exists and is worse in Internet Explorer 8.
I can confirm this issue on:
Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110531 Firefox/7.0a1

This is reproducible ever since Firefox 3.6.16
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 (.NET CLR 3.5.30729)

Setting the resolution of this issue to New.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Component: General → Print Preview
Keywords: testcase-wanted
Product: Firefox → Core
Is this issue still relevant?

It looks fine on my machine
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0

As the website and print preview look identical.
Flags: needinfo?(nrundy)
Mozilla/5.0 (Windows NT 5.2; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160210071115

I can't reproduce the issue anymore on the latest Nightly 47.0a1 on Windows XP. I'm setting the status of this issue to RESOLVED WORKSFORME.

If anyone else is still reproducing this issue, please feel free to reopen it. 

Thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(nrundy)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.