allow stronger pop-up blocking (also windows opened by user action)

VERIFIED DUPLICATE of bug 565104

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 565104
7 years ago
7 years ago

People

(Reporter: aceman, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Current pop-up blocker blocks windows opened automatically without user action. Some users wish to block also windows opened when the user clicks somewhere on a page (e.g. a form element he needs to enter) and the page opens an unwanted window. Reportedly, IE8 does this.

Some URLs:
http://sergebrussolo.free.fr (Click on "Le Masque d'argile".)
http://www.worldlingo.com/products_services/worldlingo_translator.html (click on the From menu to choose a language)
(Reporter)

Comment 1

7 years ago
See also discussion in bug 658911 and bug 658827.
(Reporter)

Updated

7 years ago
Blocks: 658827
(Reporter)

Updated

7 years ago
Blocks: 658911

Comment 2

7 years ago
See the discussions there: Bug 658911, Bug 658827.

Rationale:

> I think almost any element can hook the click event to open a new window.

In this case, the browser obeys too much the page and does not put enough the user in control. Which is, according to my sensitivity and to usability literature, very bad.

IE 8 does not that. Instead, it displays the yellow bar, in order to allow the user to show the blocked page if he really wants to. Which is a much better behaviour.

Nowadays the Web is full of this trap:

The user is attracted to the trap by a legitimate-appearing bait. The ad on a page shows a - sometimes fake - "Close" link or cross. I click on it to close the ad, and that click triggers a popup window! I just saw a popup window opening in Firefox because of that trick.

> FF popup protection is designed only to
> protect against windows that open even without you clicking anything.

In that case, that's not what Firefox advertises, and that's really not enough protection.

Some "protection feature" should not even be needed. Web browsers have evolved in the wrong way. They have included all kind of flaws: Javascript, "target" attribute... And now they are building stronger and stronger "blockers" around them. A much simpler and safer design would be: not to provide to the page any way to interact out of its frame, except in a few specific cases, safely handled and user-controlled.

Comment 3

7 years ago
About IE 8's yellow bar:

IE 8 does it better. When I click, he displays the yellow bar. If I want to see the popup window that has been blocked, then I click on the yellow bar and then things get complicated for IE; for I-forgot-which-browser, they are simple: I choose the popup window in the yellow menu, and it shows. Shows where? This is another story.
Bug 565104 seems to be about that.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565104
(Reporter)

Comment 5

7 years ago
Yes, that is true, thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.