Invalid Focus Event Information

RESOLVED DUPLICATE of bug 546812

Status

()

RESOLVED DUPLICATE of bug 546812
8 years ago
8 years ago

People

(Reporter: basiphobe, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.772.0 Safari/535.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1

The focus even that fires in the cookies list does not contain valid information.

Reproducible: Always

Steps to Reproduce:
Open the Tools -> Options dialog, navigate to Privacy, then to remove individual cookies, and press enter. Tab to the cookie list, and arrow. As you do, you get:

Actual Results:  
OBJ_FOCUS	 Name="The following cookies are stored on your computer:" Value=[bstr=NULL] Role=outline item State=selected,focused,collapsed,focusable,selectable

Expected Results:  
The name should, instead, be the text of the selected item.
Blocks: 375743
This is definitely confirmed. The individual entries get the name from the parent tree view, where they should instead get the name from the underlying cells.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Alex, re blocking bug 375743: I don't think this is related to the focus event itself, but rather, the tree view items actually inherit the name from the parent. The focus is firing on the correct item. It's just that the item's name is wrong.
Ah! I knew I'd seen this somewhere else.

Duplicate of bug 546812? If not a duplicate, it's definitely similar.
(In reply to comment #2)
> Alex, re blocking bug 375743: I don't think this is related to the focus
> event itself, but rather, the tree view items actually inherit the name from
> the parent. The focus is firing on the correct item. It's just that the
> item's name is wrong.

got it, thank you for the catch
Blocks: 459353
No longer blocks: 375743
(In reply to comment #3)
> Ah! I knew I'd seen this somewhere else.
> 
> Duplicate of bug 546812? If not a duplicate, it's definitely similar.

it is, thanks again!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 546812
You need to log in before you can comment on or make changes to this bug.