Some addons stopped working after applying bug 592943

RESOLVED FIXED

Status

()

Core
XPCOM
P1
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox5 unaffected, firefox6 unaffected, firefox7 affected)

Details

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1
Build Identifier: 

Regression Range:

Good: http://hg.mozilla.org/mozilla-central/rev/02a5505b965b
Bad:  http://hg.mozilla.org/mozilla-central/rev/eaa69ae330ab

Reproducible: Always




Some addons that no longer work with Bug fix 592943:

1. Stratiform
2. NoSquint
3. Firegestures
(Reporter)

Updated

6 years ago
Keywords: regression
Priority: -- → P1
Version: unspecified → Trunk
(Reporter)

Updated

6 years ago
Summary: Some addons stopped working with Bug fix 592943 → Some addons stopped working with [url=https://bugzilla.mozilla.org/show_bug.cgi?id=592943]Bug 592943 – switch nsXULPrototypeCache to use startupCache instead of fastload[/url]
(Reporter)

Updated

6 years ago
Summary: Some addons stopped working with [url=https://bugzilla.mozilla.org/show_bug.cgi?id=592943]Bug 592943 – switch nsXULPrototypeCache to use startupCache instead of fastload[/url] → Some addons stopped working with <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=592943">Bug 592943 – switch nsXULPrototypeCache to use startupCache instead of fastload</a>
(Reporter)

Updated

6 years ago
Summary: Some addons stopped working with <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=592943">Bug 592943 – switch nsXULPrototypeCache to use startupCache instead of fastload</a> → Some addons stopped working with https://bugzilla.mozilla.org/show_bug.cgi?id=592943
(Reporter)

Updated

6 years ago
Summary: Some addons stopped working with https://bugzilla.mozilla.org/show_bug.cgi?id=592943 → Some addons stopped working after applying https://bugzilla.mozilla.org/show_bug.cgi?id=592943

Comment 1

6 years ago
I'm the author of Stratiform. I was using encodeURI to encode some CSS to register via the style sheet service, changing to encodeURIComponent restored compatibility with the latest nightly builds. Perhaps the other add-ons are using a similar method.
(Reporter)

Comment 2

6 years ago
Did some addon testing and found that many of my addons do not work with bug fix 592943.

Comment 3

6 years ago
I just dropped back to the nightly build because the hourly (with this fix) broke NTT and Menu Editor.

Comment 4

6 years ago
(In reply to comment #1)
> I'm the author of Stratiform. I was using encodeURI to encode some CSS to
> register via the style sheet service, changing to encodeURIComponent
> restored compatibility with the latest nightly builds. Perhaps the other
> add-ons are using a similar method.

This is caused by landing Bug 658949.
And this is not related Bug 660389.

Comment 5

6 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1)
> Gecko/20110527 Firefox/7.0a1
> Build Identifier: 
> 
> Regression Range:
> 
> Good: http://hg.mozilla.org/mozilla-central/rev/02a5505b965b
> Bad:  http://hg.mozilla.org/mozilla-central/rev/eaa69ae330ab
> 
> Reproducible: Always
> 
> 
> 
> 
> Some addons that no longer work with Bug fix 592943:
> 
> 1. Stratiform
> 2. NoSquint
> 3. Firegestures


WORKAROUND:
user_pref("nglayout.debug.disable_xul_cache", true);
Blocks: 592943
Status: UNCONFIRMED → NEW
status-firefox5: --- → unaffected
status-firefox6: --- → unaffected
status-firefox7: --- → affected
tracking-firefox7: --- → ?
Ever confirmed: true

Comment 6

6 years ago
Fixed by backout.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 7

6 years ago
Confirmed
:::: Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1 #1306555932
Summary: Some addons stopped working after applying https://bugzilla.mozilla.org/show_bug.cgi?id=592943 → Some addons stopped working after applying bug 592943

Comment 8

6 years ago
I've fixed some issues with the patch and put up a build at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mwu@mozilla.com-3aca00bcdf3d/ in case someone wants to try it and see if it breaks extensions again. It shouldn't, but extra testing would be appreciated.

Updated

6 years ago
tracking-firefox7: ? → ---
You need to log in before you can comment on or make changes to this bug.