Firefox 4 is less usable then predecessor due to changes in GUI design.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: grillhuette2001, Unassigned)

Tracking

4.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729; .NET4.0C)

For many years I have been a faithful and satisfied user of Firefox. Until I recently when at work I updated from Firefox 3.xx to version 4.

I'm sad to say that I am very displeased with the changes that make an internet explorer out of my once favourite browser. 

Firefox is - as far as I'm concerned - the first browser that used tabs and I loved using tabs a lot and always preferred it to the internet explorer - among other reasons because I had got used to the look and feel of the programm.

This look and feel have gone now.

1) The context menu items "open in new window" and "open in new tab" have swapped their position thus forcing me to change a completely automated use without any clear reason. Why has Firefox become a internet explorer?
Of course I know that I'm not entitled to my habits. But the result is a severe loss of usability.

But still this unnecessary change has the annoying result that I open URLs in a new window when I want them in a new tab and the other way around.

2) Why are the tabs at the very top of the window now? Which need or problem does it solve?

3) Why is there so little space left for icons of add-ons?



Reproducible: Always

Steps to Reproduce:
1. open firefox 4
2. there it is
3. still there



Can you please change the GUI back to firefox 3.xx???

PLEASE!

Yes, this is something of little  importance to people who actually develop and maintain this browser. But I'm pretty sure there is a lot of other normal, non-geek users just as displeased as me.
Imagine somebody changes your fridge overnight so that it opens to the other side. It will take you ages to get used to it.
You can always customize your Firefox back to how Firefox 3 is. Firefox, Options, Tabs on top (uncheck). That moves tabs back underneath. As for the Open In new tab being on top, this was a decision to encourage use of tabs instead of new windows. I bet there is an addon to change this back.

Simple answer, no, the UI is not changing back. However, you can customize it to your hearts content.
Whiteboard: WONTFIX?
Version: unspecified → 4.0 Branch
(Reporter)

Comment 2

7 years ago
Thx. That is very helpful. :)
Thx for not mentioning RTFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.