Beta channel updates doesn't work against deleted versions

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: xabolcs, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: 

The "beta section" of AMO policy says:
Once a file meeting this criteria is uploaded to AMO, it will automatically be marked as a beta version. Users of add-ons with these unique version numbers will automatically be served the newest beta updates.

But versioncheck.addons.mozilla.org serves the latest compatible version of addon if checking updates for an old, deleted beta version.

Reproducible: Always

Steps to Reproduce:
1. got an old, unlisted version number from addon's changelog or statistics
for example MR2 on Air!: 0.8.6pre.20110113a

2. got a valid, listed beta version
for example MR2 on Air!: 0.8.6pre.20110527a

3. check v.a.m.o against them

Actual Results:  
Testing with MR2 on Air! with non-existent beta version 0.8.6pre.20110113a the latest, compatible and fully reviewed version (0.8.5) is listed.



Expected Results:  
Testing with MR2 on Air! with non-existent beta version 0.8.6pre.20110113a the latest beta version should be listed.

"Users of add-ons with these unique version numbers will automatically be served the newest beta updates."
VersionCheck sould follow this.

The AMO's addon maintenance policy (https://addons.mozilla.org/en-US/developers/docs/policies/maintenance#beta-addons) says:
If you understand regex format, here's what we look for in the version number: "(a|alpha|b|beta|pre|rc)\d*$".

Once a file meeting this criteria is uploaded to AMO, it will automatically be marked as a beta version. Users of add-ons with these unique version numbers will automatically be served the newest beta updates.
(Reporter)

Comment 1

8 years ago
Created attachment 535929 [details]
activity: deleted versions

Deleted versions of my addon, grabbed from activity feed:


Version 0.8.4pre.20100624a deleted from MR2 on Air!.
Version 0.8.4pre.20100624a2 deleted from MR2 on Air!.
Version 0.8.4pre.20100630a deleted from MR2 on Air!.
Version 0.8.4pre.20100701a deleted from MR2 on Air!.
Version 0.8.4pre.20100715a deleted from MR2 on Air!.
Version 0.8.5pre.20100824a deleted from MR2 on Air!.
Version 0.8.6pre.20110519a deleted from MR2 on Air!.
Version 0.8.4pre.20100615a deleted from MR2 on Air!.
Version 0.8.6pre.20110113a deleted from MR2 on Air!.
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.