Printer Error - Not Available message when trying to Save as PDF

NEW
Unassigned

Status

()

Firefox for Android
General
7 years ago
4 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({regression, testcase})

Trunk
ARM
Android
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox17 affected, fennec-)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 535992 [details]
Printer Error

Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110529 Firefox/7.0a1 Fennec/7.0a1

When attempting to save any page as PDF a very generic modal dialog appears with a message, "Printer Error - Not Available". See screenshot.

STR:
1. http://www.lifehacker.com
2. Hit the device menu button, and hit More -> Save as PDF

ER: Page saved to device as a PDF
AR: "Printer Error: Not available"
(Reporter)

Updated

7 years ago
Priority: -- → P1
This works for me in current trunk build, using the LG Optimus Black.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> This works for me in current trunk build, using the LG Optimus Black.

If you dont see it the first time, and you try to save as PDF again (twice) do you see it?
No, it still works for me.

Comment 4

7 years ago
Unable to reproduce on the 5/29 build for a nexus S.   lowering priority and awaiting more STR.
Priority: P1 → P3
(Reporter)

Comment 5

7 years ago
Device: HT Nexus One.

I reproduced this today on the 06/06 Nightly.

1. www.lifehacker.com
2. Rotated my device to landscape
3. Continually hitting More and Save Page as PDF

I'm not always able to trigger the error on first download, for example today I get the error after my third or fourth attempt and thenceforth on each and every attempt to Save as PDF afterwards. I suspect the same error happens on Beta and Aurora as well since the Save as PDF code has not been touched in a while.
Ok, I've managed to reproduce this.

I'm seeing this explicitly on http://www.lifehacker.com , so you need to go there.
I keep getting redirected to the mobile version, so you need to have the Phony extension installed and use the Desktop Firefox user agent.
Then you have to quickly use Save Page as PDF 2 times after each other.

My guess is that on the first time, the browser hasn't finished with printing the page yet and that's why you get the error the second time.
Created attachment 537577 [details]
testcase

You get something similar with this testcase, which just prints very slowly in Firefox (on desktop and mobile).
On desktop Firefox you get a progress bar, which a normal user would wait for, but you can still see the error there, too, with the testcase I attached.
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> Created attachment 537577 [details]
> testcase
> 
> You get something similar with this testcase, which just prints very slowly
> in Firefox (on desktop and mobile).
> On desktop Firefox you get a progress bar, which a normal user would wait
> for, but you can still see the error there, too, with the testcase I
> attached.

Yes same error when I save as PDF on that attachment too.
(Reporter)

Comment 9

7 years ago
So I think the resolve here is to override that desktop error message and replace it with something that makes sense for mobile now that we know what the issue is, "Page is currently being saved to PDF" or something similar.
We could just disable the "Save as PDF" command until the current PDF has finished saving.
You should als disable the save as PDF command for xul documents (like about:config).
This issue doesn't occur on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.b8pre)Gecko/20101116
Firefox/4.0b8pre Fennec/4.0b3pre
http://hg.mozilla.org/mozilla-central/rev/a42e9b001bc8

"Save as PDF" option was not available in this build

but it occurs on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.b8pre)Gecko/20101117
Firefox/4.0b8pre Fennec/4.0b3pre
http://hg.mozilla.org/mozilla-central/rev/c3c229aaf531

"Save as PDF" option was added in this build.

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a42e9b001bc8&tochange=c3c229aaf531
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Yes, sorry, the 'regression-window' keyword should have been removed. This is very much tied to how print to PDF is working.
(Reporter)

Comment 14

7 years ago
Reopening due to ability to reproduce on testcase provided in comment #7
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Keywords: regressionwindow-wanted → testcase
(Reporter)

Updated

6 years ago
Duplicate of this bug: 750900
(Reporter)

Updated

6 years ago
Component: General → General
Product: Fennec → Fennec Native
(Reporter)

Updated

6 years ago
Priority: P3 → --

Comment 16

6 years ago
I'm getting this on Firefox 14.0.1 for Windows 7 on a laptop, whenever I choose File->Print, intending to print to PDF.  It occurs after trying to print to PDF and failing to do so or being interrupted by the Cancel button after hanging (10 min) at 16%.

Comment 17

6 years ago
Also, the "Not Available" dialog is tab-specific.  I get the print dialog on all tabs except the one that previously failed - admittedly quite a large document, but after about a day of compute time with pretty much nothing else running on the machine, it should be able to print.
Duplicate of this bug: 704442
I am still able to reproduce this issue on the latest Nightly build. Also I have several saved pdf files in sdcard/downloads, but their size is 0KB. However there is nothing listed in Firefox Downloads manager.

--
Firefox 17.0a1 (2012-08-09)
Device: Galaxy Nexus
OS: Android 4.1.1
tracking-fennec: --- → ?
status-firefox17: --- → affected
tracking-fennec: ? → -
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1029573
(Reporter)

Comment 21

4 years ago
I get this not with the test-case anymore but on the Firefox Marketplace (as showcased in the dupe above).

Nothing shown in logcat. It would be helpful to know why this 'Printer Error' occurs and show a better message to the user.
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.