Last Comment Bug 660584 - nsILanguageAtomService.LookupLanguage should use nsACString instead of nsAString
: nsILanguageAtomService.LookupLanguage should use nsACString instead of nsAString
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla7
Assigned To: Makoto Kato [:m_kato]
:
:
Mentors:
Depends on:
Blocks: 181520
  Show dependency treegraph
 
Reported: 2011-05-29 22:02 PDT by Makoto Kato [:m_kato]
Modified: 2011-05-30 22:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.91 KB, patch)
2011-05-30 01:14 PDT, Makoto Kato [:m_kato]
smontagu: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-05-29 22:02:05 PDT
http://mxr.mozilla.org/comm-central/search?string=LookupLanguage

nsILanguageAtomService::LookupLanguage is only used by gfxFontconfigUtils.cpp.  So we should use nsACString instead of nsAString because this parameter is language.
Comment 1 Makoto Kato [:m_kato] 2011-05-30 01:14:13 PDT
Created attachment 536024 [details] [diff] [review]
fix
Comment 2 Makoto Kato [:m_kato] 2011-05-30 22:45:03 PDT
http://hg.mozilla.org/mozilla-central/rev/49297a8fbf27

Note You need to log in before you can comment on or make changes to this bug.