Firefox showing blank page even when it has downloaded the full source code

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
8 years ago
3 years ago

People

(Reporter: kierantmurphy, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.65 Safari/534.24
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.17) Gecko/20110420 (CK-IBM) Firefox/3.6.17 GTB7.1

Firefox shows a blank page even when it has downloaded the full source code and the status in the bottom left of the browser windows says "Done". Pressing F5 to refresh the page usually corrects the problem. This happens only from time to time so is tricky to reproduce. 

The following bugs also report this issue for earlier versions of the browser so it seems like its been around a while:
https://bugzilla.mozilla.org/show_bug.cgi?id=508960
https://bugzilla.mozilla.org/show_bug.cgi?id=531981


Reproducible: Sometimes
Please update to Firefox 4.0.1, uninstall the Google Toolbar, then create a fresh profile and test there again. http://support.mozilla.com/kb/Managing+profiles
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
Thanks for your reply. Updating to Firefox 4 is not an option unfortunately as the web application I am working on can only support Firefox 3.6 for the moment until we add support for Firefox 4.
Then please follow my other requests.

Comment 4

8 years ago
Reporter -> Are you still experiencing this issue? Have you tried safe mode or a new profile?
(Reporter)

Comment 5

8 years ago
Hi Tim, I only see this issue from time to time. The next time it happens I'm going to try creating a new profile and see how that works out. I will provide feedback here again. Thanks, Kieran.
(Reporter)

Comment 6

8 years ago
Hi, I got the blank screen again even after I created a new profile. I didn't have the Google Toolbar installed either.

Comment 7

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 6? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
(Reporter)

Comment 8

7 years ago
Hi, thanks for the response. I am seeing this issue with 3.6. I have not tried version 4, 5 or 6. As already mentioned above updating to versions beyond 3.6 is not an option at this time for the web application I am working on. For the moment we plan to support version 3.6 only. I have already tried removing the Google toolbar and creating a new profile and this did not work. If there is anything else I could try please let me know.

Comment 9

7 years ago
The best bet might be to try and capture an HTTP log when it happens. Instructions at https://developer.mozilla.org/en/HTTP_Logging
Whiteboard: Can't upgrade to latest FF

Comment 10

7 years ago
Any updates?

Comment 11

7 years ago
I was having this trouble when trying to view the http://www.HTML-5.com/ site, but it seemed pretty consistent and repeatable with all of the pages on that site, and they worked fine in other browsers including Chrome and Opera.

I tried to do the HTTP log as suggested above, but the log.txt file was empty, even after reloading the page.  It turned out that even after closing Firefox there still was a firefox.exe process running.  After terminating that process the pages on the HTML-5.com site loaded fine, without having to do the reload.

So if you're having this trouble on Windows, one possible solution is this:

1. Close Firefox
2. Start Task Manager and check for a process named "firefox.exe"
3. Terminate that process
4. Try loading the page that failed again
5. If it still fails, capture the HTTP log per https://developer.mozilla.org/en/HTTP_Logging

Comment 12

7 years ago
That was on Firefox 10.0.2.

Comment 13

7 years ago
Created attachment 606628 [details]
log.txt with NSPR_LOG_MODULES=nsHttp:5,nsSocketTransport:5,nsHostResolver:5

I think I have recreated the issue on Firefox 11, although the symptoms are slightly different.  This time there weren't any firefox.exe processes running when I started Firefox to get the log.

Steps to recreate:
1. Start Firefox with logging enabled.
2. Go to Google and search for "site:html-5.com" (without the quotes)
3. Click on one of the links
4. Note that the page is not displayed, even though it appears to have downloaded the full source code.
5. Try to display the context menu and/or select text to copy.
6. Do the same thing in other browsers, where it works.

Comment 14

4 years ago
Rob, do you still see this when using a current version?
http://www.html-5.com/ no longer exists
Flags: needinfo?(Rob.Simpson)
Keywords: testcase-wanted
Whiteboard: Can't upgrade to latest FF → [closeme 2015-01-10]

Comment 15

4 years ago
All;

I submit my own instance that I believe is relevant. However, like the original context, it is awkward to describe. I can admit that it does only seem to be doing this on certain pages, and I submit my own client website as an example of this scenario.

Additionally, IE (10+), Safari, Opera, and Chromium have no problem with this scenario.

User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
* This also is occuring on Windows 8.1 latest Firefox release as of Jan 10th, 2015.

Steps:
1. Load a webpage (example: http://www.goinghome.ca). Page loads (HTTP 200, with expiration info so page should go into Cache).
2. Refresh the page. Server returns HTTP 304 (Not Modified). Correct Request and Response headers. Expect: Load from cache. Result: Blank white page shown.
3. Refresh the page again. Exact same headers go out and back -- 304 Not Modified. Expect: Load from cache. Result: Page loads from cache (I know it loads from cache because the server did not send Content with a 304).

Screenshots provided for steps 2 and 3.

Comment 16

4 years ago
* Edit to Comment 15 @ https://bugzilla.mozilla.org/show_bug.cgi?id=660607#c15

Attachments available, but don't seen a way to attach them.
The Steps to reproduce in comment 15 works fine for me using a fresh profile.
Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0

(In reply to ap from comment #16)
> Attachments available, but don't seen a way to attach them.

There's an "Add an attachment" link on this page.

Comment 18

4 years ago
Page from Comment 15 now have no-cache in response, so steps are no longer applicable.
As both Rob and original reporter didn't reply, closing this per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(Rob.Simpson)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-01-10]
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.