Mozilla internal urls should NOT be placed into the history list

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
P3
normal
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Ronald van Kuijk, Assigned: Alec Flett)

Tracking

({arch})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Behaviour:

When I start mozilla a lot of internal urls get into the history-list. This is
annoying, especially when sorted on 'last visited' because they are making up
the complete history window (sidebar and normal history list)

The format is:  http://3:nonce<number>@127.0.0.1:<dynamic portnumber/<some info>

Expected behaviour:
No internal urls in the history list.

Build: 2001012006
OS:
Linux 2.2.16

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

17 years ago
Also 'banner links' get into the history list... I (we?) don't want these
either. (should this be a new bug?)

For an example go to http://www.gamez.com and look at the history list.
--> alecf
Assignee: radha → alecf
(Assignee)

Comment 3

17 years ago
Do you use a proxy server? I'm surprised to see 127.0.0.1 on there, and I
certainly am not getting them in my history.

As for the "banner links" you describe, I'm also not seeing this.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 4

17 years ago
no response from filer, can't reproduce, marking invalid.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Target Milestone: mozilla1.0 → Future
(Reporter)

Comment 5

17 years ago
I did not see it in the 25-01 nightly on windows... I'll check the linux version
as well and yes I am (was?) using a proxy... but I'll check that to.  
(Reporter)

Comment 6

17 years ago
Problem is gone on 2001012506 build on linux

Leaving as resolved 
(Reporter)

Comment 7

17 years ago
Sorry, but I reopen this bug as the 'banner' or 'add' links show up on
http://www.javaworld.com. For the homepage 6 http://add.doubleclick.net show up
in the history list.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 8

17 years ago
By coincidence I saw that the internal urls DO show up, but not anymore at
startup. They show up if you open PSM by clicking on the bottom-right lock
(Assignee)

Comment 9

17 years ago
those URLs are the banner ads themselves, not the links.
The banner ads (the images) should be showing up in global history - that is as
designed - every image shows up in global history, banner ad or not.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

17 years ago
I can accept this explanation if it happend on *every* site. But images (banner
ads) do not appear in the history list on every site (e.g. http://www.cnn.com).
There is only a redirect there (which was another bug/rfe as i've seen).

I think I'll file a RFE on this, as there is another issue. Al frames on
http://www.telegraaf.nl get into the sidebar-history. I can accept that they are
in the 'normal' history list, but not the sidebar history since it is *not* a
link I visited, but something that comes with the site design.

The 'internal' PSM urls do not show up in the sidebar (or the normal
history-list) on the 2001012620 build on windows95 I'll check linux again tonight. 

Imo the things that should be in the sidebar history should be (almost)
identical to the dropdown go-menu. Otherwise the sidebar history is to full even
if when it gets hierarchical.

To be continued ;-)

Updated

17 years ago
Status: RESOLVED → REOPENED
Keywords: arch
OS: Linux → All
Hardware: PC → All
Resolution: INVALID → ---
Summary: Mozilla internal urls get into history list → Mozilla internal urls should NOT be placed into the history list
Target Milestone: Future → ---

Comment 11

17 years ago
alecf. according to #mozillazine, history is any thing you visit on your own.  
here are my testcases:
Case J
javascript:document.write("<html><title>About Bar</title><frameset 
rows='33%,*,33%'><frame src=about:><frame src=about:mozilla><frame 
src=about:credits></frameset></html>")
Case D
data:text/html,<html><title>About Bar</title><frameset rows='33%,*,33%'><frame 
src=about:><frame src=about:mozilla><frame 
src=about:credits></frameset></html>")
Case N
data:text/html,<html><title>About AOL</title><frameset cols='33%,*,33%'><frame 
src=www.aol.com><frame src=www.cnn.com><frame 
src=www.netscape.com></frameset></html>
My view is that the history should have one entry 'About Bar', for each of the 
two urls.  There should be one go entry for each of the two urls.
Case O
javascript:document.write("<html><title>About AOL</title><frameset 
cols='33%,*,33%'><frame src=www.aol.com><frame src=www.cnn.com><frame 
src=www.netscape.com></frameset></html>")
Case E
javascript:document.write("<html><title>About AOL</title><frameset 
cols='33%,*,33%'><frame src=http://www.aol.com><frame 
src=http://www.cnn.com><frame src=http://www.netscape.com></frameset></html>")
Case A
data:text/html,<html><title>About AOL</title><frameset cols='33%,*,33%'><frame 
src=http://www.aol.com><frame src=http://www.cnn.com><frame 
src=http://www.netscape.com></frameset></html>

Build: 1/24-20 
D: 1 History item, 1 Go menuitem
J: 0 History items, 3 Go menuitems.
N:
Attempt one: Crash.
Attempt two: [from about:blank] 1 History, 1 Go, 3 Blank Frames
Attempt three: [from http://localhost/index.html jakarata] 1 History, 1 Go, 3 
Blank Frames
O:
[from about:blank] 0 History, 0 Go, 3 Blank Frames
[from http://localhost/index.html jakarata] 4 History [About AOL, and an error 
for each url not found on localhost], 4 Go [All 'About AOL'], 3 Error Frames, 
one per document
E:
Attempt one: 8 History [4 are ads.web.aol.com], 0 Go, 3 Frames, 1 New Window 
[looks like it'shttp://home.netscape.com/misc/popup.html?93029208]. Moments 
later [after playing w/ the popup] cnn.com captures the window
Error loading URL javascript:document.write("<html><title>About 
AOL</title><frameset cols='33%,*,33%'><frame src=http://www.aol.com><frame 
src=http://www.cnn.com><frame src=http://www.netscape.com></frameset></html>"): 
804b0002
Attempt two: 7 History [4 are ads.web.aol.com], 0 Go, 3 Frames
Error loading URL javascript:document.write("<html><title>About 
AOL</title><frameset cols='33%,*,33%'><frame src=http://www.aol.com><frame 
src=http://www.cnn.com><frame src=http://www.netscape.com></frameset></html>"): 
804b0002
Attempt three: 6 History [4 are ads.web.aol.com], 0 Go, 3 Frames [middle empty]
Error loading URL javascript:document.write("<html><title>About 
AOL</title><frameset cols='33%,*,33%'><frame src=http://www.aol.com><frame 
src=http://www.cnn.com><frame src=http://www.netscape.com></frameset></html>"): 
804b0002
case A: 8 History [4 are ads.web.aol.com], 2 Go [first was About AOL, second is 
CNN.com], 3 frames were created.  CNN rewrote the window.

... hrm, http://www.cnn.com/ line 443: document.specials1.showlist has no 
properties

We can ignore the fact that cnn is evil or wierd.

When i visit these testcases I should get 1 history item, either about bar or 
about aol.  Ideally, that same item should appear in the go menu.  If 
javascript errors prevents it and someone can explain how i can fix that, then 
with it fixed, i expect that behavior.

history is not cache, i have a bug filed for a cache window.  If the user 
doesn't visit the page, it doesn't belong in history.  I think that even means 
that only chrome based responses to user interactions should be historied [ie, 
clicking on <a href="http://localhost">clickme</a> should enter history but, 
<a onclick="document.location.href='http://localhost'">clickme</a> might not 
belong in history], or maybe things should only be historied if there's a user 
event that can be shown to have triggered a page.  Web sites should not be able 
to poison web browser's history list.
(Assignee)

Comment 12

17 years ago
I don't understand why this bug got reopened. This is Global History, not url
bar history.
Everything is working as designed. 
I'm not going to wade through 8 million wacky test cases. If you find a specific
test case that matches the description of this bug, put it here.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

17 years ago
I don't want to be rude, but work on the history sidebar should stop as far a
I'm  concerned and work on a 'go-sidebar' should be started. If the sidebar
history gets filled the way it does now (even when it's 'threaded') I'm *never*
going to use it... 

I'll try to create a complete test page somewhere in this week (or maybe
timeless@max.com already has made complete test-cases?)
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.