Closed Bug 660769 Opened 11 years ago Closed 10 years ago

"Letter apostrophe" in Better Internet blurb

Categories

(www.mozilla.org :: General, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: steffen.imhof, Assigned: steffen.imhof)

References

()

Details

Attachments

(1 file)

396 bytes, text/plain;charset=utf-8
davidwboswell
: review+
Details
The apostrophe used in the "Weʼre Building a Better Internet" banner on www.mozilla.org seems to be a "Letter apostrophe" U+02bc which is not the right smart apostrophe for this case.

Note that the apostrophe used in the subtitle "And we’re dedicated to keeping it free, open and accessible to all." is the right one (U+2019, "Right single quotation mark").

Admittedly not that important, but I encountered a case where the wrong apostrophe was not shown correctly.
(In reply to comment #0)
> The apostrophe used in the "Weʼre Building a Better Internet" banner on
> www.mozilla.org seems to be a "Letter apostrophe" U+02bc which is not the
> right smart apostrophe for this case.

Indeed, you are correct. The letter apostrophe is a letter in the IPA (and certain languages' orthographies). It is not a letter in English, so it should definitely not be there.

> Note that the apostrophe used in the subtitle "And we’re dedicated to
> keeping it free, open and accessible to all." is the right one (U+2019,
> "Right single quotation mark").

This is also correct, and interesting, I think.

> Admittedly not that important, but I encountered a case where the wrong
> apostrophe was not shown correctly.

It actually is important, for a couple of reason: The first being already mentioned, that (because it is a glyph from the IPA modifier letters block) it might not be displayed properly for everyone. But also for a more fundamental reason: It's a *letter* apostrophe. That means it's as wrong as if the title actually said "Weʃre Building a Better Internet" or something silly like that. I'm pretty sure the only similarity between a letter apostrophe and a "regular" apostrophe is how they look; they are functionally completely distinct.
Steffen, thanks for reporting this.  Would you be interested in submitting a patch for this?  Gordon and/or I can walk you through the process of submitting a patch, getting in on stage for testing and then getting a review to check it into the live site.
> Would you be interested in submitting a patch for this?

Sure, why not :-) I tried to follow what I know about patches to the "normal" code. Please advise if that is not suitable for the website.

So far I checked out https://svn.mozilla.org/projects/mozilla.org/branches/staging, made the change locally and the attached patch is the result of "svn diff".
Assignee: nobody → steffen.imhof
Status: NEW → ASSIGNED
Attachment #536608 - Flags: review?(dboswell)
Steffan, thanks for that.

I may be looking at the patch incorrectly but it's looking garbled to me.  I used your initial comment though to look up the correct HTML identify and used that.

Take a look at stage to see if things look good now (it may be a few minutes before the change goes live).

For reference, you can check a diff at

http://viewvc.svn.mozilla.org/vc?view=revision&revision=89753

If this looks good on stage, I'll move to production.
Apologies, I meant Steffen in my last comment :)
Hmmm, that's not working properly on stage -- the HTML entity itself is showing up instead of the apostrophe.  That line itself seems fine and shows properly on a test page with just that line.  Maybe something with the javascript that's rotating the two blurbs in?
(In reply to comment #6)
> Hmmm, that's not working properly on stage -- the HTML entity itself is
> showing up instead of the apostrophe.  That line itself seems fine and shows
> properly on a test page with just that line.  Maybe something with the
> javascript that's rotating the two blurbs in?

Yeah, I think it is well possible that the createTextNode() automatically escapes the text given. Did you try my patch? It looks a bit garbled when looking at the ASCII representation of the UTF-8 encoded apostrophes, but in principle I think it should work. (I basically copied the correct apostrophe from the subtitle to the title).
Attachment #536608 - Attachment is patch: false
Attachment #536608 - Attachment mime type: text/plain → text/plain;charset=utf-8
I'm not sure if this is useful or not, but I at least ungarbled the attachment when I viewed it by adding ;charset=utf-8 to the mime-type.

Gordon, would you have a chance to check in this patch on stage and see if you have better luck?  This might be better handled by someone with a better grasp of these sorts of things :)
(In reply to comment #8)
> I'm not sure if this is useful or not, but I at least ungarbled the
> attachment when I viewed it by adding ;charset=utf-8 to the mime-type.
> 
> Gordon, would you have a chance to check in this patch on stage and see if
> you have better luck?  This might be better handled by someone with a better
> grasp of these sorts of things :)

AFAICT, you successfully applied the patch in r90174.
I can confirm that www-stage.mozilla.org looks good to me now, thanks.
Great, glad to hear that worked.

I just applied this to production in r90337.  Steffan or Gordon, could you confirm there too please?  It might take 15 minutes or so for the change to show up.
(In reply to comment #11)
> I just applied this to production in r90337.  Steffan or Gordon, could you
> confirm there too please?  It might take 15 minutes or so for the change to
> show up.

Well, it appears to be the right apostrophe, but you somehow managed to add a space after it. (And the diff in ViewVC doesn't show the apostrophe at all in the trunk version; it shows fine in the staging branch.)
I tried doing the exact same thing on production that I did on stage and also tried copying over the change from stage, but just couldn't get it to show up correctly on production.  Clearly I'm doing something wrong -- we should try to get someone else to give checking this in a try.
Ha ha, I like the current solution of using "We are" instead of "We're".

If the application of the patch does not work reliably, can you try to do it by hand: Basically copying the apostrophe from the subtitle into the offending title?

OTOH if you want to keep the "We are" that's fine with me, too. Feel free to resolve the bug then.
(In reply to comment #14)
> Ha ha, I like the current solution of using "We are" instead of "We're".

It was an act of desperation on my part :)

> If the application of the patch does not work reliably, can you try to do it
> by hand: Basically copying the apostrophe from the subtitle into the
> offending title?

I tried adding this to the home page about 6 different ways.  I'm not that familiar with UTF issues and may just be doing this completely wrong (although it did seem to work on stage).

> OTOH if you want to keep the "We are" that's fine with me, too. Feel free to
> resolve the bug then.

I'm fine going back to "we're" if someone else wants to take a pass at applying the patch.

Steffen, btw, if you're interested in getting involved with other www.mozilla.org projects we'd love your help.
I just pushed a fix to trunk in r93384. (Forgive the trailing whitespace removal.)

Resolving this as FIXED, but reopen it if there's still an issue.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Attachment #536608 - Flags: review?(dboswell) → review+
Duplicate of this bug: 659736
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.