Closed Bug 660887 Opened 9 years ago Closed 8 years ago

Double tap on an empty space on the tab bar should open a new tab

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 10

People

(Reporter: padenot, Assigned: mbrubeck)

References

Details

(Keywords: platform-parity, ux-consistency, ux-efficiency)

Attachments

(1 file, 2 obsolete files)

When using Fennec for the first time, I tried to double tap on an empty space on the tab bar, to open a new tab, and this didn't work.

I guess this behavior should be implemented, as it is consistent with the desktop browser (double click on an empty space opens a new tab).
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → 21
Attachment #536339 - Flags: review?(mark.finkle)
This is a duplicate of bug 563973.
on IRC, Madhava said he did not want to add this feature to the core browser. It's too hidden and could be executed during an accidental double-tap more often than in desktop Firefox.

An add-on could add this behavior if it wanted to.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Attachment #536339 - Flags: review?(mark.finkle)
I don't think we want to do this. Doubletap isn't really a widely used interaction on touch devices other than for zoom - I'm not sure that it's worth using this as a one-off interaction for something where there is a easy and near-at-hand alternative (the button).
Duplicate of this bug: 563973
Duplicate of this bug: 692285
For me, holding a tablet, the button isn't near at hand. It's a long reach for my reasonably lengthy thumb. 

Also, I don't care about this on phones and my bug which was duped here was filed against tablets and not phones if that makes a difference in reconsidering the wontfix.
Attached patch patch (obsolete) — Splinter Review
I agree this is worth re-opening because of tablets.

This patch is basically like Vivien's, but it uses "TapDouble" instead of "dblclick" because dblclick is hard to trigger on a touchscreen.  (You have to tap twice in pretty much exactly the same place for dblclick, while TapDouble is more lenient.)
Assignee: 21 → mbrubeck
Attachment #536339 - Attachment is obsolete: true
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Duplicate of this bug: 692285
Status: REOPENED → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Whiteboard: [has patch]
You're right for dblclick in general but in this case it's not really relevant since the tab bar is huge :) But dblclick will probably not fired for some platforms so TapDouble is likely the right approach. The only thing I don't like is using BrowserUI.addTab() directly into tabs.xml, could you use the same mechanism use for reloadtab & co?
Attached patch patch v2Splinter Review
This addresses Vivien's comments above.

This also adds a clickcount="1" filter to the main onclick handler, to prevent it from firing at the same time as a TapDouble.  (Without that change, if your double-tap hits an existing tab, then it opens a new tab but selects the old tab.)
Attachment #565064 - Attachment is obsolete: true
Attachment #565119 - Flags: review?(mark.finkle)
Comment on attachment 565119 [details] [diff] [review]
patch v2


>   <binding id="tablist">

>     </content>
>+    <handlers>
>+      <handler event="TapDouble" action="this._onDoubleTap();"/>
>+    </handlers>
>     <implementation>

Add blank lines before and after

r+, but you still need Madhava's approval on this
Attachment #565119 - Flags: ui-review?(madhava)
Attachment #565119 - Flags: review?(mark.finkle)
Attachment #565119 - Flags: review+
So this won't work on the mobile phone, only on tablet?
This patch will actually work on in both the phone and and tablet layouts.
OK. let's land it and see what we think.
https://hg.mozilla.org/integration/mozilla-inbound/rev/979075e871e2
Keywords: uiwanted
Whiteboard: [has patch] → [pushed]
Target Milestone: --- → Firefox 10
Attachment #565119 - Flags: ui-review?(madhava) → ui-review+
Depends on: 692811
Backed out because the Fennecmark Tzoom benchmark breaks with this change:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ab95694a2977

Filed bug 692811 for fixing Fennecmark.  When that is fixed, we can re-land this patch.
Whiteboard: [pushed] → [blocked on dependencies]
https://hg.mozilla.org/mozilla-central/rev/81d3eb93437d
Status: ASSIGNED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → FIXED
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111031 Firefox/10.0a1 Fennec/10.0a1
Device: HTC Desire Z - Android 2.3
        Asus Transformer TF101 - Android 3.1

Verified on phone and tablet: when double tapping on an empty space on the tab bar a new tab is opened.

Also when double tapping on an existing tab, a new tab is opened and the tapped tab is selected. Is this a expected, or is it a new issue?
You need to log in before you can comment on or make changes to this bug.