Recommended status is incorrect for search tools/themes

VERIFIED FIXED in 6.1.1

Status

addons.mozilla.org Graveyard
API
P3
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: Andy McKay)

Tracking

unspecified
6.1.1

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 536349 [details]
screenshot

steps to reproduce:
1. Load https://addons.allizom.org/en-US/firefox/api/1.5/search/searchpreview
2. Notice the value of <featured>

expected behavior:
<featured>1</featured> since Search Preview is  featured (https://addons.mozilla.org/en-US/firefox/addon/searchpreview/)

observed behavior:
For search tools, the recommended status is 0
(Reporter)

Updated

7 years ago
Summary: Recommended status is incorrect for search tools → Recommended status is incorrect for search tools/themes
-> andym did this
Assignee: nobody → amckay
Priority: -- → P3
Target Milestone: 6.0.12 → 6.1.1
(Assignee)

Comment 3

7 years ago
It looks like there's a few different concepts of being featured. Search tools and Themes have custom code to decide if the show up in the browse view.
(Assignee)

Comment 4

7 years ago
Comment 0: Search tools uses category featured (and shows featured on the buttons). So I've added that in for searchpreview.

https://github.com/jbalogh/zamboni/commit/bb70380abbe97935ef39a446e3d668407ae77fc6

Comment 1: Walnut is a theme and shows up on the browse pages but that doesn't mean its featured. The theme page just show the listed addons.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

7 years ago
Themes and search tools have featured = 1

verified at
https://addons.allizom.org/en-US/firefox/api/1.5/search/walnut
https://addons.allizom.org/en-US/firefox/api/1.5/search/searchpreview
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.