If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

MailNews Core
Composition
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Pekka Sarnila, Assigned: Akkana Peck)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; 0.7) Gecko/20010120
BuildID:    own build of 0.7 sources

in plain text mode you can't indent with space(s). If you use tab it looks
alright but for the receiver result is totally messy.

Reproducible: Always
Steps to Reproduce:
1.set compose mail in plain text in preferences
2.try to indent with space to consecutive lines.
3.indent with tab.send mail
4.look the result in the other end (in in SENT folder)

Actual Results:  1-2 sencond line autoindented in a way not wanted (more than on
space)
3-4 line breaks are lost.

Expected Results:  1-2 no auto indent
3-4 line break are greated when auto wraping

both problems are really result of auto wraping not adding line breaks. Adding
line breaks IMHO should be default behaviour.

Well you have invented nice way to avoid bug reports. You have made it
so tedious that most people will say: what the heck I'll use netscape
instead. I think your policy is not to the best advantage of your
project. Certainly it's very anoying and although I can see your logic there it
gives kind of unpleasant impression of your guys.

Updated

17 years ago
QA Contact: esther → pmock

Comment 1

17 years ago
Reporter, I have just tried to reproduce this with build 2001020820
(Mozilla0.8), and I could not reproduce the bug. Typing white spaces works
correctly. Tabbing once brings the caret only two characters further, but once I
type a character the tab is corrected. I believe there is already a bug filed on
that.
Could you please try again with Mozilla 0.8 (latest nightly)? Thank you a lot
for your help.
On a side note : This bug system has proven to work well for Mozilla. If people
want to use Netscape, we have no problem with that (after all they are our
allies), and personally I think it is really not so hard to use. It simply makes
sure that our developers get the needed information in order to fix the bugs.
Reassigning to akkana@netscape.com
Assignee: ducarroz → akkana
(Assignee)

Comment 2

17 years ago
I don't understand the problem described in the bug report, so I can't suggest
who should own it if there is indeed a bug.  What auto-indent are you expecting
and where, and what do line breaks have to do with inserting spaces?

Comment 3

17 years ago
is this bug #58712?

Comment 4

17 years ago
this works fine in the 2/21/01 build, the lines are preserved and the indents 
all remain and are rendered correctly.

marking wfm -- Sujay, can youplease double check on your linux machine?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
QA Contact: pmock → sujay

Comment 5

16 years ago
marking verified..REOPEN if problem still persists...provide reproducible
steps/testcase
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.