Featured flag missing for add-on buttons

VERIFIED FIXED in 6.1.4

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: potch)

Tracking

unspecified
6.1.4

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 536450 [details]
screenshot

steps to reproduce:
1. Load https://addons.allizom.org/z/en-us/firefox/i/addon/foxyproxy-standard/
2. Notice the install button

observed behavior:
Featured flag is missing from the install buttons.
Chowse, do we have mockups for what featured add-on badges are supposed to look like?
Assignee: nobody → chowse
Target Milestone: 6.0.12 → 6.1.0
Target Milestone: 6.1.0 → 6.1.1
(Assignee)

Comment 2

7 years ago
I took a crack at them:

https://github.com/jbalogh/zamboni/commit/44af4c1
(In reply to comment #2)
> I took a crack at them:
> 
> https://github.com/jbalogh/zamboni/commit/44af4c1

Localizers will have a ball with that :)  (also, text-instead-of-image ftw)


Chowse - what's going on with this bug?
(In reply to comment #3)
> (In reply to comment #2)
> > I took a crack at them:
> > 
> > https://github.com/jbalogh/zamboni/commit/44af4c1
> 
> Localizers will have a ball with that :)  (also, text-instead-of-image ftw)

Potch's update is the intended design for featured add-ons (top-right banner, same colors as the Featured decal on listing pages).

I'd only suggest two (optional) tweaks:

* Move the banner 2px up and to the right, so it appears to "wrap around" the
  main block.

* Bump the vertical padding around the block up to 7px (or .5em). I think it's
  a little scrawny at the moment.
Thanks, back to potch for the tweak and we can close
Assignee: chowse → thepotch
Target Milestone: 6.1.1 → 6.1.3
Target Milestone: 6.1.3 → 6.1.4
(Assignee)

Comment 6

7 years ago
This is all spruced up now!
https://github.com/jbalogh/zamboni/commit/29bf21ab07
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

7 years ago
verified fixed @ https://addons-next.allizom.org/z/en-US/firefox/i/addon/stumbleupon/
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Blocks: 671142
(Assignee)

Updated

7 years ago
No longer blocks: 671142
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.