Last Comment Bug 661045 - Devirtualize some RasterImage methods
: Devirtualize some RasterImage methods
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 16:35 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-09-19 13:40 PDT (History)
2 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.62 KB, patch)
2011-05-31 16:35 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
joe: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-05-31 16:35:40 PDT
Created attachment 536471 [details] [diff] [review]
Patch

We know the concrete type at compile time, so these being virtual just adds overhead.
Comment 1 Daniel Holbert [:dholbert] 2011-05-31 16:41:33 PDT
Just for history -- these have been virtual ever since they were moved from imgIContainer.idl into RasterImage, in this cset:
 http://hg.mozilla.org/mozilla-central/rev/205795b2962a

I don't think I intentionally made them virtual - I may have just done it mechanically, with the idea of mostly preserving the methods' signatures as they were shifted off of the interface.

So anyway, I fully support this change. :)
Comment 2 Joe Drew (not getting mail) 2011-06-09 11:26:12 PDT
Comment on attachment 536471 [details] [diff] [review]
Patch

Review of attachment 536471 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-06-11 12:29:47 PDT
http://hg.mozilla.org/mozilla-central/rev/51b64ac421e3

Note You need to log in before you can comment on or make changes to this bug.