Carriage return symbol '
' is ignored: no newline inserted

RESOLVED DUPLICATE of bug 565035

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 565035
7 years ago
7 years ago

People

(Reporter: Mikhail Sazonov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:7.0a1) Gecko/20110531 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:7.0a1) Gecko/20110531 Firefox/7.0a1

If a text on a page contains carriage return symbols like '
' it is ignored and no newline inserted. It results in very long lines in preformatted blocks, which use this symbol as line delimeter.
It works well in other browsers, e.g. in IE 8, as well as in Firefox versions prior to 4.0.

Reproducible: Always

Steps to Reproduce:
1. Open a page containing symbols &#013; as line delimeter in a <pre> block.



Actual Results:  
All lines are displayed in one line without separation.

Expected Results:  
Each symbol &#013; should be replaced by a new line.
(Reporter)

Comment 1

7 years ago
Created attachment 536530 [details]
Test case

Comment 2

7 years ago
Workaround: use &#10;
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565035
(Reporter)

Comment 3

7 years ago
1. I do not agree with such workaround. I am a user of some web service, not a WEB developer of it. And I would like this bug be fixed in order I could see the page as expected.
2. The bug 565035 is about another thing: treatment \r as a white space symbol, not as a line separator in <pre> blocks.

Comment 4

7 years ago
(In reply to comment #3)
> 1. I do not agree with such workaround.
Nothing someone needs to agree with, just a fact and worth to note for others running into this issue. Fixes also the same problem in Safari and Google Chrome.
> I would like this bug be fixed
Yes, nobody indicated this big as INVALID or WONTFIX.

> 2. The bug 565035 is about another thing
No, it's not. (When Henry reported it in May 2010 maybe the impact wasn't clear to him until he saw Bug 650643)
(Reporter)

Comment 5

7 years ago
Thanks, now I see.
For me, I disabled HTML5.parser to return to the old behavior.

Comment 6

7 years ago
> For me, I disabled HTML5.parser to return to the old behavior.
Don't forget to reset, this setting reanimates tons of old parsing bugs ...
(Reporter)

Comment 7

7 years ago
Eventually, I have reset HTML5.parser setting, after our organization has changed the internal bug tracker to another product.
So, now this issue does not bother me any more.
Thanks for the support.
You need to log in before you can comment on or make changes to this bug.