Content process crashes don't display uptime

RESOLVED FIXED in 1.7.8

Status

Socorro
General
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jdm, Assigned: rhelmer)

Tracking

Trunk
1.7.8
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Example: https://crash-stats.mozilla.com/report/index/55a916c9-8e78-4fa4-89b2-1eeec2110528

Ted pulled the JSON from another similar crash, and both CrashTime and StartupTime are present: http://pastebin.mozilla.org/1240259

I'm absolutely certain that Uptime used to be displayed when I added StartupTime to content process crash dumps, so something must have regressed with Socorro since then.
(Reporter)

Comment 1

7 years ago
Also, the list of multiple crashes displays uptime just fine: https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-06-01%2003%3A00%3A00&signature=nsWebSocketEstablishedConnection%3A%3AConsoleError&version=Fennec%3A7.0a1
(Assignee)

Comment 2

7 years ago
Looks like the uptime for this crash is only 9 seconds:

https://crash-stats.mozilla.com/dumps/55a916c9-8e78-4fa4-89b2-1eeec2110528.jsonz

And for some reason the function returns an empty string if this value is under 3 minutes:

http://code.google.com/p/socorro/source/browse/trunk/webapp-php/application/libraries/timeutil.php#88

Simple fix would be to return seconds instead of empty string in this case; not sure what's so special about 3 minutes though (why not 1 minute?)
(Assignee)

Comment 3

7 years ago
Ted points out this regressed here:
http://code.google.com/p/socorro/source/detail?r=2957&path=/trunk/webapp-php/application/views/report/index.php

The "ghetto_time_ago_in_words" time formatting function was not used here before then.
(Assignee)

Updated

7 years ago
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
Target Milestone: --- → 1.7.8
(Assignee)

Comment 4

7 years ago
Created attachment 536712 [details] [diff] [review]
stop using "ghetto_time_ago_in_words"

also this function name annoys me greatly, but leaving that for a different bug :)
Attachment #536712 - Flags: review?(bsavage)
(Assignee)

Comment 5

7 years ago
This is minor enough we should take for 1.7.8 (shipping tomorrow) assuming landing this on trunk doesn't cause anything to explode
Comment on attachment 536712 [details] [diff] [review]
stop using "ghetto_time_ago_in_words"

Review of attachment 536712 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not a huge fan of necessarily backing the change out, but I think it's our lowest risk course of action with a ship date of less than 24 hours from now.

We'll file a bug to fix the underlying issue in the 2.0 release.
Attachment #536712 - Flags: review?(bsavage) → review+
(Assignee)

Comment 7

7 years ago
Filed bug to followup

Landed on trunk:
Committed revision 3185.

Going to make sure it looks ok on crash-stats-dev before landing on 178 branch.
(Assignee)

Comment 8

7 years ago
Looks ok on crash-stats-dev (would be nice if it was formatted ;) but leaving that to followup):

Committed revision 3186.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.