Last Comment Bug 661172 - The GCLI popup menu should be accessible in addition to the main command line
: The GCLI popup menu should be accessible in addition to the main command line
Status: RESOLVED FIXED
[best:2d, likely:3d, worst:6d]
: access
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 717424 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-01 07:55 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-07-16 05:44 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-01 07:55:51 PDT
Bug 653567 deals with the accessibility of the command line itself. We expect the popup help to be checked in in a later release, so I'm separating the 2 parts of the job.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-03 02:51:13 PDT
Tricky to estimate because it's likely to involve lots of to and fro. Elapsed time likely to be much longer than estimates.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-09-08 02:48:55 PDT
This part of GCLI is getting close to landing, so I'd like to get some accessibility feedback if possible.

There is a demo on the web: https://people.mozilla.com/~jwalker/gcli/

Firefox developer tools will be using something very similar to this (same codebase) to replace the Javascript command line.

The change from the last time we talked about GCLI is that in addition to an input box, there is now a hint area which can take user input.

The hint area is designed to help discoverability. So I would like to ensure that it is voiced properly, and I've added aria-live attributes to do this.

Normally we would ensure that things are keyboard accessible, and I expect this to be too, however I suspect that for the most part keyboard access will be to the command line.
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-18 10:00:20 PST
Moving GCLI bugs to Developer Tools: Console. Filter on 'baked beans are off'.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-29 02:11:00 PST
*** Bug 717424 has been marked as a duplicate of this bug. ***
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-04-29 10:18:34 PDT
GCLI Triage.
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-16 05:44:08 PDT
GCLI is accessible as far as I know how. If we have problems then we should raise specific issues for them.

Triage, filter on TEABAGS

Note You need to log in before you can comment on or make changes to this bug.