All users were logged out of Bugzilla on October 13th, 2018

Status

()

8 years ago
5 years ago

People

(Reporter: miguel.wherner, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b10) Gecko/20110126 Firefox/4.0b10
Build Identifier: Mozilla/5.0 Gecko/20110126 Firefox/4.0b10 (I'm faking user agent, I use Debian Squeeze with Firefox 4.0.1

When you click on a malformed link it redirects to http.com

Reproducible: Always

Steps to Reproduce:
1.go to http://www.guardian.co.uk/politics/2011/jun/01/panorama-care-home-abuse-investigation-government-review
2. Click on link that says "documented by an undercover cameraman and broadcast on the BBC's Panorama " and points to "http://http//www.guardian.co.uk/society/2011/may/31/abuse-at-leading-care-home"
3. End up in http.com, a landing page that has no content and is full of ads.

Alternative: just put http://http://google.com and you end up in http.com

Actual Results:  
You en up in http.com, a landing page with no content and full of ads

Expected Results:  
Error saying the link has a wrong format or been redirected to the page I wanted to go.
Say "http://http://google.com" should take me to google, not to http.com.

I'm using Noscript and Adblock plus other plugins, haven't tested disabling all of them.
That link is actually a bad link, http://http//www.guardian.co.uk/society/2011/may/31/abuse-at-leading-care-home is not a real website, it should be http//www.guardian.co.uk/society/2011/may/31/abuse-at-leading-care-home. But you shouldn't be getting a redirect. Try a fresh profile,
(Reporter)

Comment 2

8 years ago
Not trying to be rude but...Did you read the bug report? Did you test if this happens to you?
In the bug report I mention that the link is wrongly formatted already.
Then you go on suggesting I try a fresh profile, I did now and it happens anyway.
So if this is confirmed as happening to everyone, then you didn't even tested, it seems you posted just for the sake of it.
Why do you assume that everyone can reproduce an issue ?
I get an Gecko error page stating: "Address Not Found http could not be found. Please check the name and try again." and the URL is
http://http//www.guardian.co.uk/society/2011/may/31/abuse-at-leading-care-home

Note: It's a difference if you put such a broken URL in the URL bar or if you get this as link on a page.
That you get this result if you put such a broken URL bar is expected but it should not happen with links in pages.

Comment 4

8 years ago
What are values of browser.fixup.alternate.* prefs in about:config ?
However, I don't think that link is bad. I think it is valid and should contact server 'http' (which can exist in local LAN or have an alias in /etc/hosts) and get file 'www.guardian.co.uk/society/2011/may/31/abuse-at-leading-care-home'. The // may easily 'eaten' by the server and may be interpreted as /. Try it on http.com.

The problem is only, why is firefox contacting http.com (which succeeds) instead of http (which should probably fail in your setup but not necessarily others).
(Reporter)

Comment 5

8 years ago
Here are my browser.fixup.alternate.*

browser.fixup.alternate.enabled;true
browser.fixup.alternate.prefix;www.
browser.fixup.alternate.suffix;.com

@aceman: Do you have the same issue? Can we put this in CONFIRMED? 
I have Firefox 4.0.1, Linux Debian, default profile.

@Matthias Versen (Matti): the error reported happens even when in your url bar you just put http://http://google.com and you end up in http.com

Comment 6

8 years ago
What is the exact link you are trying to write, because bugzilla seems to mangle it. Is it:
1. http : / / http / / google.com
or
2. http : / / http : / / google.com ?

Till now I couldn't reproduce it on my Win XP machine. But now as you say it, I see it on my linux machine, when typing both those urls into urlbar and also when clicking the link in your comment 5 (which is actually the one without the second colon).

I'd say in the first case the fixup feature really should fix the url (if 'http' server is not found on local LAN) to http://www.http.com//google.com and is working as designed. If you do not wish this, turn it off (browser.fixup.alternate.enabled).
The second case is questionable, FF maybe could see this is wrong (two colons) and do something else.
The third case is bad, fixup whouldn't work on clicked links. So I confirm.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

7 years ago
@aceman: Both 1 and 2 take me to http.com
Which is the third case?

I just tested with "Gecko/20110430 Iceweasel/3.5.16 (like Firefox/3.5.16)" on Linux Debian and both 1 and 2 take me to http.com too.

Have you tried with a default profile?

Comment 8

7 years ago
Third case is "clicking the link in your comment 5".

Comment 9

7 years ago
Mos: Does this still happen in a recent version of Firefox?
Version: unspecified → 4.0 Branch

Comment 10

7 years ago
Mos ?
Whiteboard: [closeme 2012-04-15]
(Reporter)

Comment 11

7 years ago
Sorry for the delay, I have been very busy and I don't check my mail that often.

Yes, still happens, just tried with Debian Squeeze Stable, Mozilla Firefox 9.0.1 default profile without plugins.

Comment 12

6 years ago
Still reproducible on today nightly, when paste http://http://google.com to Location bar it changes to correct http://google.com but still going to http.com
OS: Linux → All
Hardware: x86 → All
Whiteboard: [closeme 2012-04-15]
Version: 4.0 Branch → Trunk
(Reporter)

Comment 13

6 years ago
Yep, still reproducible with Firefox 12 on Linux.

Comment 14

5 years ago
Still reproducible on Firefox 29.0. (Tested on Linux).
(In reply to Phoenix from comment #12)
> Still reproducible on today nightly, when paste http://http://google.com to
> Location bar it changes to correct http://google.com but still going to
> http.com

It is the expected behavior when you are pasting it to the location bar. "http:" is a valid hostport part of the URI (host "http" wuth the empty port).
All other reports are on Linux.
OS: All → Linux
You need to log in before you can comment on or make changes to this bug.