If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

June Newsletter - Copy Request

RESOLVED FIXED

Status

Marketing
Copy
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Winston Bowden, Assigned: matej)

Tracking

Details

Attachments

(5 attachments, 2 obsolete attachments)

129.45 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
26.50 KB, application/msword
Details
17.19 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
29.00 KB, application/msword
Details
19.50 KB, application/msword
Details
(Reporter)

Description

7 years ago
Working on outline for june newsletter.  Will submit on Monday, June 6.  Hoping to have copy finalized by June 14.
(Assignee)

Comment 1

7 years ago
Sounds good. Let me know if you want to chat or brainstorm on this.
(Reporter)

Comment 2

7 years ago
Sweet.  Adding Laura to the bug. Two big content pieces will depend on her projects.  We have Mark up from last month as a secondary story.  Laura and I are also going to discuss how to highlight the latest Firefox release.  That'll be the lead feature.  Also, we're shooting to distribute on the same day new Firefox version is available.
Cool. I'll upload the Fx 5 stuff here--I want to do it Friday, so you should have that from me that afternoon.
Outline: Firefox 5 Email Story

This is a bit long, so feel free to cut stuff.

Next version of Firefox is here!

We're really excited that the new version of Firefox is ready!
This release is all about momentum and continuing to improve the awesome of Firefox 4 as part of a faster release process that gets you the newest features in Firefox as quickly as possible.

What's New

1) Firefox 4 brought you Do Not Track, a feature that lets you indicate to advertisers that you do not want to be tracked.  With this new version, you'll see the option to enable DNT from your Privacy Tab of your Preferences menu

[screenshot]

2) Smoother scrolling and More UI Polish:  Scrolling through pages is going to feel even more seamless than with Fx 4.  We've also put a lot of effort into Pixel polish, so your browser looks and feels even cleaner.

3) We've partnered with NVidia to bring 3D HTML5 videos to the Web through Firefox. Using Vision Hardware, you are able to see several thousand special 3D HTML5 videos on Youtube when using Firefox 4 or higher.
Link to blog:http://www.0xdeadbeef.com/weblog/2011/05/bringing-the-first-3d-html5-video-to-the-web-with-firefox-nvidia-and-youtube/

4) Along with over-all stability and performance enhancements, we have also added support for CSS Animations which will allow developers to build even more amazing Web experiences with graphics and video.
-https://developer.mozilla.org/en/CSS/CSS_animations

5) Add-On Builder makes it easy for Web develoeprs to build compelling Firefox Add-Ons by providing more resources and building environments for developers to choose from. Developers can also choose to build add-ons that installa nd update withour interrupting the browsing experience. 

To install the latest version of Firefox go to your About Firefox menu and search for update--the latest version should download automatically.

[screenshot can be added if you want]
Blocks: 655402
(Reporter)

Comment 5

6 years ago
Created attachment 537624 [details]
June Newsletter

Draft copy/bullets attached.  There are a few small pieces we're waiting on, but this is the bulk.  I should have the final pieces tomorrow.
(Reporter)

Comment 6

6 years ago
Remaining pieces:

Add-ons

- Intro this month that talks about all three... but equally weight the twitter add-on with the pick of the month.  

Desktop Pick Of The Month: 

1. Search GBY: https://addons.mozilla.org//firefox/addon/searchgby-205586/

Runner-ups:

2. Twitter: https://addons.mozilla.org/firefox/addon/twitter-address-bar-search/?src=ryfx
3. Tab Utilities: https://addons.mozilla.org/firefox/addon/tab-utilities/

Mobile Pick Of The Month: 

1. URL Fixer: https://addons.mozilla.org/mobile/addon/url-fixer/

Runner-up: 

2. Easy Reading: https://addons.mozilla.org/mobile/addon/easy-reading/
(Reporter)

Comment 7

6 years ago
Update - they decided we will use Twitter as the pick of the month.  So let's focus on that for our Add-on intro. Updated:

Desktop Pick Of The Month: 

1. Twitter: https://addons.mozilla.org/firefox/addon/twitter-address-bar-search/?src=ryfx

Runner-ups:

2. Search GBY: https://addons.mozilla.org//firefox/addon/searchgby-205586/
3. Tab Utilities: https://addons.mozilla.org/firefox/addon/tab-utilities/
(Assignee)

Comment 8

6 years ago
Created attachment 538375 [details]
June Newsletter — First Draft

Hi all, here's a first draft of this month's newsletter (and early, too!). Winston, I think I got everything in there, but I wasn't sure about "today's tip" at the end of your document. There was nothing below that, so I wasn't sure if I was supposed to come up with something. Let me know.
(Reporter)

Comment 9

6 years ago
Thanks Matej.  Working on edits today.  Having the product team take a look at the Firefox 5 pieces.
(Reporter)

Comment 10

6 years ago
Created attachment 539284 [details]
Edits to intro / feature

Comments attached.  Laura M and Mayumi also reviewed.  One big piece - we need to bring in some mobile points.  Asking Caitlin for some bullets.
(Assignee)

Comment 11

6 years ago
Thanks Winston. Would you have time to get on a call today to talk through some of these points?
(Assignee)

Comment 12

6 years ago
Created attachment 539330 [details]
June Newsletter — Intro & Feature revised

Here are the changes, minus the Mobile bullet point. I can send you that separately once I know what it should cover. Let me know what you think.
(Assignee)

Comment 13

6 years ago
Created attachment 539535 [details]
June Newsletter — Intro & Feature revised (really real version)

OK, here it is again, with mobile. I made some other changes and tweaks as well, so please disregard what I send yesterday. Thanks!
Attachment #539330 - Attachment is obsolete: true
(Reporter)

Comment 14

6 years ago
Created attachment 539614 [details]
NExt round of comments

Hey Matej - few more comments.  Nothing major.  Hit me up if you'd like to go over the edits.
(Assignee)

Comment 15

6 years ago
If we could chat, that would be great.
(Assignee)

Comment 16

6 years ago
Created attachment 539651 [details]
Latest & greatest version

Peep it, yo!
Attachment #539535 - Attachment is obsolete: true
Hey Mattej--

This looks good--just wanted to clarify a few things according to Mayumi's comments that are still there. 

1) The CTA is still at the bottom of the copy--is there a way to include it earlier?
2)Do we want to add something like "join the millions of users" are using this feature for the DNT section?
3) Not sure what Mayumi means by link to the video--I think we can delete that.
4)I like Developer Extras title
5) You do clarify that everyone = advertisers, so thanks for that.
6) Thanks for explaining how to update.
(Reporter)

Comment 18

6 years ago
We decided to keep the CTA where it is.  We have one right above it in the intro where we'll link to the download pages.  

+1 on comment 2.
(Assignee)

Comment 19

6 years ago
(In reply to comment #17)
> Hey Mattej--
> 
> This looks good--just wanted to clarify a few things according to Mayumi's
> comments that are still there. 
> 
> 1) The CTA is still at the bottom of the copy--is there a way to include it
> earlier?

I talked to Winston about this. We felt like having it twice in the feature story was a bit much and it seems natural at the end of the section. So instead of adding it to the feature intro, we added a download CTA for both desktop and mobile to the overall newsletter intro. Does that work for you guys?

> 2)Do we want to add something like "join the millions of users" are using
> this feature for the DNT section?

That's my bad. I meant to do it and then totally spaced. Here you go:

Privacy — Do Not Track does just what it says: lets you tell advertisers you don’t want them to track your information and we're working with them to make sure that happens. They're not all on board yet, but we've seen some real progress. We first introduced the feature in Firefox 4 and now you’ll find it in the Privacy tab of the Preferences menu. Join the millions of users already using this new privacy feature.

> 3) Not sure what Mayumi means by link to the video--I think we can delete
> that.

Winston was going to add a hyperlink from something in the current text.
(In reply to comment #19)
> (In reply to comment #17)
> > Hey Mattej--
> > 
> > This looks good--just wanted to clarify a few things according to Mayumi's
> > comments that are still there. 
> > 
> > 1) The CTA is still at the bottom of the copy--is there a way to include it
> > earlier?
> 
> I talked to Winston about this. We felt like having it twice in the feature
> story was a bit much and it seems natural at the end of the section. So
> instead of adding it to the feature intro, we added a download CTA for both
> desktop and mobile to the overall newsletter intro. Does that work for you
> guys?

Ah, there it is ;)  I'm assuming we'll make it bold or something so it sticks out in that paragraph?
> 
> > 2)Do we want to add something like "join the millions of users" are using
> > this feature for the DNT section?
> 
> That's my bad. I meant to do it and then totally spaced. Here you go:
> 
> Privacy — Do Not Track does just what it says: lets you tell advertisers you
> don’t want them to track your information and we're working with them to
> make sure that happens. They're not all on board yet, but we've seen some
> real progress. We first introduced the feature in Firefox 4 and now you’ll
> find it in the Privacy tab of the Preferences menu. Join the millions of
> users already using this new privacy feature.

+1
> 
> > 3) Not sure what Mayumi means by link to the video--I think we can delete
> > that.
> 
> Winston was going to add a hyperlink from something in the current text.
Ah, ok. Winston, do you have what you need?
(Reporter)

Comment 21

6 years ago
Thanks all - yes - think we're set.  Really appreciate the quick review.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 660846
You need to log in before you can comment on or make changes to this bug.