Closed Bug 661337 Opened 10 years ago Closed 10 years ago

newlines are not copied when copying from no-<pre> element with white-space:pre style set

Categories

(Core :: DOM: Serializers, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 116083

People

(Reporter: eentotenmetdrie, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

When copying multi-line data from a <code> area that did NOT use <br/> for newlines but used a style property of white-space:pre instead, the newlines did not get copied to my clipboard.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://gogomakeplay.com/gmp/manual/tutorial1-hello-world
2. Copy one of the code parts from the page
3. Paste the resulting code in a text editor that can handle Windows-, Mac- and Linux style newlines.

Actual Results:  
The code that was copied and pasted in the editor consists of one single line

Expected Results:  
The copied code should contain the newlines that were displayed at the web page.

Tested using the latest stable version of Firefox (4.0.1), with both add-ons turned on and off and in both private and normal browsing mode.
Version: unspecified → 4.0 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Component: General → Serializers
Product: Firefox → Core
QA Contact: general → dom-to-text
Resolution: --- → DUPLICATE
Version: 4.0 Branch → Trunk
Duplicate of bug: 116083
You need to log in before you can comment on or make changes to this bug.