Selecting last character in line should highlight whole line

RESOLVED DUPLICATE of bug 46784

Status

()

Core
Selection
RESOLVED DUPLICATE of bug 46784
18 years ago
18 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: mjudge)

Tracking

({pp})

Trunk
mozilla0.8
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2001011912, Mac OS 9.0

To reproduce:
* In any HTML text form control, or XP Toolkit textfield, or editor (e.g.
  message composition window), enter some text.
* Select all the text (e.g. by typing Command+A).

What should happen:
* The whole of the lines containing the selected text should be highlighted with
  the selection color.

What actually happens:
* Just the characters in the text are highlighted.

This bug is most clearly visible in textareas and Composer -- if you select a
line which contains only a line break, there is no visual indication that you
have selected the line at all.

Comment 1

18 years ago
-> selection
Assignee: beppe → mjudge
Component: Editor → Selection
QA Contact: sujay → blakeross

Comment 2

18 years ago
Matthew--I think this is a duplicate of bug #46784.  If not, please reopen.
(Note: #46784 isn't intended to be specific to textareas; it should apply to all 
editors)


*** This bug has been marked as a duplicate of 46784 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla0.8
(Reporter)

Comment 3

18 years ago
Well, this bug is pp for Ma OS, and bug 46784 is on Windows. Both bugs solve 
the problem of not being able to see a selected line, but they solve it in 
different ways on different OSes.

A carriage return should be treated as an invisible character which is the same 
width as a space character (but which does not affect the width of a line for 
wrapping purposes). When this character is selected on Windows, it should be 
highlighted (this is how native apps, other than Internet Explorer, behave). 
When it is selected on Mac OS, however, the entire line should be highlighted.

You can see the difference by typing a few characters in a native text field on 
either OS, and then selecting all the characters; on Windows, the characters 
will be highlighted, whereas on Mac OS the entire field will be highlighted.

So this is a dup only if you want to cover both implementations in bug 46784 at 
once.
Keywords: pp
OS: All → Mac System 8.5
Hardware: All → Macintosh
You need to log in before you can comment on or make changes to this bug.