Flash banner "bleeds" outside browser window

NEW
Unassigned

Status

()

Core
Layout: View Rendering
7 years ago
6 years ago

People

(Reporter: Karo, Unassigned)

Tracking

({flashplayer})

2.0 Branch
x86
Windows XP
flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When (this particular) page is scrolled by arrow-keys towards top of the page, flash banner in the top shows (renders) partly outside (above) the top border of the browser window.
It doesn't happen when scrollbar is dragged, or with mousewheel, only with arrow keys, or by clicking the scrollbar arrow.


Reproducible: Always

Steps to Reproduce:
1. Visit the page, http://www.nacional.hr/kategorija/extra-zona .
2. Scroll a bit down, to hide whole or part of the banner.
3. Scroll back up using arrow keys or clicking crollbar arrow up.

Actual Results:  
In every other scroll step, banner renders partly outside of browser window. Inbetween those steps, renders normally.

Expected Results:  
Banner is supposed to "disappear under" the chrome above the window along with the rest of the page.

I've tried this with other pages with banners, but could not reproduce it. By the behaviour of this banner, it may have some scrolling trick to it (like switching fixed and static positions in css) although i wasn't able to locate it in FireBug.

Regardless of that though, page content of any kind being rendered outside of window is something i have never seen in any browser till now.
(Reporter)

Comment 1

7 years ago
Created attachment 536863 [details]
Screenshot of the bug in 3 stages of scroll

Screenshot
(Reporter)

Comment 2

7 years ago
I've noticed that the position of the banner doesn't change in every other step, (which is what made me think it has some JS position trick), and that's when it bleeds out. 

Scrolling looks like this, step by step (each step is a keypress of up-arrow, or click on up-arrow on scrollbar):

step 1 - normal, page moves a bit down.
step 2 - page moves down, but banner stays in place, being rendered 0.5 cm above it's supposed position, and bleeds outside of window.
step 3 - normal, page moves a bit down, banner in its proper place.
step 4 - page moves, banner stays in place, bleeding.
etc...
Version: unspecified → 4.0 Branch
Please post the modified Prefs and Contents of the Graphics Section of "about:support".
(Reporter)

Comment 4

7 years ago
it seems to be a long list... do i paste it here or attach as some kind of doc?
You can attach as a Text File.

Is your Issue reproducible in Safe-Mode, btw?
https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 6

7 years ago
Created attachment 536925 [details]
Modified Preferences and Graphics
(Reporter)

Comment 7

7 years ago
Yes, reproducible in Safe-Mode!

Comment 8

7 years ago
Can you post a screenshot in safe mode with disabled HW acceleration? I do not see this on Win XP, Intel card.
It also seems the banner is misplaced on your screenshot. I have the banner nicely aligned with the red Nacional banner. You say in comment 2 the banner jumps in its position, sometimes it is properly places, sometimes not. What is your flash plugin version (about:addons)?
(Reporter)

Comment 9

7 years ago
Created attachment 537514 [details]
Screenshot in Safe Mode, HW Acc. disabled
(Reporter)

Comment 10

7 years ago
Shockwave Flash 10.1.82.76 
(10.1 r82)

Not sure if it's vidible from version number, but it's a Debug version of flash player (i'm a AS3 developer). Perhaps that may be why you can't reproduce it.

Screenshot is of a step when it happens. As i said, in every other step, it is ok. Also it happens only when scrolling back up (towards top of page)

NOTE: When testing, make sure you have a flash banner loaded - i see that about half of their banners are images, which don't have the problem. If so, reload till you get a flash one.
(Reporter)

Comment 11

7 years ago
The up-shift of the banner from it's proper position looks about the same as the bleeding part (cca 20 pixels), so apparently it "only" displaces the banner in every other step 20 px up. Except that the displacement disregards the fact that the window ends there :)

Comment 12

7 years ago
I tried it with 9.0.0.332 :) Yes, I have got a Flash banner. What is the difference between a Debug version and normal version? Can you temporarily try with any normal version (of the same flash version or some never 10.3)?

Can you reproduce it on any other machine or other browsers on your machine?
(Reporter)

Comment 13

7 years ago
I don't know what's the "internal" difference, but debug version displays run-time errors. It also crashes more often :) (sometimes, when error window pops up)

I can try to temporarily install a normal player, but not in next few days, as i'm chasing an important but tight deadline at the moment...
(Reporter)

Comment 14

7 years ago
and no, i don't get the problem in any other browser

Comment 15

7 years ago
I could try your flash version if you can provide a download for it (WinXP 32bit). But no installer, only the NPSWF32.dll (or an archive to extract). Or send it to my email.
(Reporter)

Comment 16

7 years ago
i found 9 (!) versions of NPSWF32.dll on my system, with different dates and filesizes. Most are in C:\ProgramFiles\Adobe subfolders, and one (largest filesize) in C:\WINDOWS\system32\Macromed\Flash ... Is it this one you need, or do i pack them all?

Comment 17

7 years ago
What a mess:) I would need the one your Firefox is actually using (debug version 10.1.82.76).
1. Check in addon manager if only one Flash plugin is enabled.
2. In about:config, toggle plugin.expose_full_path to true.
3. Visit about:plugins and you will see which flash file FF is really using. 
4. Send me that file.
5. toggle the pref in step 2. back to false (it is a security risk leaving it on true).
(Reporter)

Comment 18

7 years ago
download at:
http://www.mjestopodsuncem.com/temp/NPSWF32.rar

Comment 19

7 years ago
Thanks, got it. But I can still not reproduce with it. The banner works fine. However I see the flash banner is draws specially. When I toggle on/off some toolbar from an extension I see the banner jump. It moves alone to a new position up (as the whole viewarea is moving to fill the place of the toolbar) and after that the rest of the page moves. The plugin object is drawn differently than other parts of the page. Maybe flash is drawing directly onto the screen and therefore can overwrite anything? But I have also never seen this, like you say. I have also tried without out-of-process plugins, but no change.
(Reporter)

Comment 20

7 years ago
Well then i guess the bug is nothing to worry about too much - probably very few users will see it. Even i don't get this behaviour on other sites with flash banners. 
As for flash drawing directly on the screen, i don't know much about flash plugin's inner workings, but i'm an experienced flash developer and i know there is no way to control the end-drawing procedures with actionscript. Besides, i get this behaviour with all flash banners ON THIS SITE, so it's obviously not about the banner itself (it was just by chance that it's the same banner il both attached screenshots), but something to do with the way it's embedded in the page; but i couldn't figure out what's so special about it in this site. 
It sure is a curious and unique bug, but seeing you can't reproduce it with even same player and same system, it probably takes convergence of many (hardware) factors to happen; and i guess you guys have more urgent FF4 bugs to deal with.
In any case, if i can assist you some more, let me know!

Comment 21

7 years ago
Can you try disabling hardware acceleration inside Flash? It is in the rightclick menu of Flash object and Settings... The Settings item is disabled on that site but you can probably find any other site where it is enabled (e.g. www.atlas.sk). Disable it there and then return to the problem site (restart FF). I hope the setting is global for flash plugin.
(Reporter)

Comment 22

7 years ago
The setting does seem to be global (i tested), but disabling it doesn't help the bug.

Btw, found anouther site where i have it:
http://www.business.hr/hr/Kompanije/Preuzimanja-i-spajanja/IN2-kupio-dvije-hrvatske-softverske-tvrtke

Comment 23

7 years ago
Where is the problem on that site? I see a banner on right side, but it is always kept in the middle (vertical) of the page.

What a broken site, if the window is not wide enough to fit the width of the content (with the banner), you can scroll to the right infinitely. And the banner always hides behind the right margin.

Comment 24

7 years ago
Ah, there is a second banner on the top, which may be what you talk about.
Are you able to find the source of those problematic banners? Aren't they served from the same ad server?
(Reporter)

Comment 25

7 years ago
Yes, i meant the top banner.
No, they're not from same ad server, but each from the website's own ad subdomain.

The sidebar banners are from doubleclick.net, but i don't get the bug with them.
(Funny enough, i don't get the buggy page behaviuor you describe. Works fine for me however i resize the window)

================
Perhaps a clue regarding the bleeding bug: now i see i don't get the bug unless the window is maximized. If it is "floating", i don't get it regardless of the window size i resize to.

Comment 26

7 years ago
Have you tried disabling out-of-process-plugins (dom.ipc.plugins.enabled)?
(Reporter)

Comment 27

7 years ago
I did now - and yep, that does it! Finally some change :)
I have to restart FF after disabling/enabling them to see the change in behaviour.

Comment 28

7 years ago
Yes, you have to restart FF. Good to hear we have some change :)
Now turn it back on and try also setting:
mozilla.plugins.use_layers to false (create the boolean pref, if it doesn't exist in about:config)
layers.acceleration.disabled to true
(Reporter)

Comment 29

7 years ago
i get the bug with this setting.

Comment 30

7 years ago
OK. So, I can't reproduce the bug, however we have done a lot of tests and it seems Firefox settings influence the problem. I'll mark this bug as NEW, so that anybody more knowledgeable can look into it whether this really is a problem in FF or we can do anything about it. Maybe there is a problem in the new asynchronous plugin drawing implemented in FF4.

Can you confirm the problem does not exist in FF 3.6.17 regardless of the setting of dom.ipc.plugins.enabled ?
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → plugins
Version: 4.0 Branch → 2.0 Branch
(Reporter)

Comment 31

7 years ago
"asynchronous" does sound right, considering for example that the bug happens with every other scrolling step, and that when switching between tabs, often the banner is drawn slightly before the rest of the page appears...

re 3.6.17 - how? De-install 4 and install 3.6? I have neither the time currently, nor the old installer... but tme is bigger issue for me a.t.m., i'm really in **** with the current deadline, for another 7 days or so.
Component: Plug-ins → General
Product: Core → Firefox
Version: 2.0 Branch → 4.0 Branch

Comment 32

7 years ago
It would be enough to download .zip package of 3.6.17 from mozilla.org, extract it somewhere and run it from there (firefox3.6.17/firefox -P <newprofile>).

It should be asynchronous on a more micro scale, like the plugins can draw at 50fps but Firefox only takes every third frame from it and puts it on the page. With slow scrolling like we have here it shouldn't be noticable whether the drawing is sync or async. But there may be a bug in the async path so the drawing is different and buggy.
Component: General → Layout: View Rendering
Keywords: flashplayer
Product: Firefox → Core
QA Contact: plugins → layout.view-rendering
Version: 4.0 Branch → 2.0 Branch
(Reporter)

Comment 33

7 years ago
could you provide a url for the zip? can't find it on m site...

Comment 34

7 years ago
This is Windowed Flash. I'm not sure it's something we really need to worry about.

Comment 35

7 years ago
Yeah, it is increasingly hard to get a zip build of a released version from mozilla. I think this version could suffice:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-firefox-3.6.x/firefox-3.6.18pre.en-US.win32.zip .
And be sure to create a new Firefox profile for the test (or backup your old one), so your production one doesn't get screwed.

Comment 36

7 years ago
(In reply to comment #34)
> This is Windowed Flash. I'm not sure it's something we really need to worry
> about.

Why? Is this mode of operation not supported?

Comment 37

7 years ago
Another odd case of clip regions not getting set down in widget, maybe due to page load? Not sure, cc'ing roc as he's spent a lot of time on this code. FWIW, I can't reproduce on the page provided.

Updated

6 years ago
Duplicate of this bug: 701515
You need to log in before you can comment on or make changes to this bug.