Validator regression test for 6.* overlay compatibility warning

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Compatibility Tools
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: kumar, Unassigned)

Tracking

Details

(Whiteboard: [validator-tests])

Attachments

(1 attachment)

When the attached addon is validated with:

overrides = {"targetapp_maxVersion": {'{ec8030f7-c20a-464f-9b0e-13a3a9e97384}': '6.*'}}
for_appversions = {'{ec8030f7-c20a-464f-9b0e-13a3a9e97384}': ['6.*']}

Assert a warning about overlay is displayed: "Your add-on has an overlay that uses the insertbefore or insertafter attribute pointing to menuitems that have been moved to a different menu item. Your overlay items may appear in unexpected locations because of this. See https://bugzilla.mozilla.org/show_bug.cgi?id=653221 for more information."
Whiteboard: [validator-tests]
Assignee: nobody → kumar.mcmillan
Created attachment 536908 [details]
addon with incompatible overlay
Removing myself from a bunch of old AMO bugs
Assignee: kumar.mcmillan → nobody
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.