Validator regression test for navigator.language compatibility warning

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Compatibility Tools
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: kumar, Unassigned)

Tracking

Details

Attachments

(1 attachment)

When validating attached addon with these parameters:

overrides = {"targetapp_maxVersion": {'{ec8030f7-c20a-464f-9b0e-13a3a9e97384}': '4.0.*'}}
for_appversions = {'{ec8030f7-c20a-464f-9b0e-13a3a9e97384}': ['4.0.*']}

assert that a *compatibility* warning about navigator.language is displayed.

Instead, this warning may be obscuring it: "Your add-on contains a large number of global variables..." since the context points to navigator.language

compatibility warnings should always be included in output when determined=True.
Assignee: nobody → mbasta
Created attachment 536911 [details]
addon with incompatible navigator.language
Whoops, this is the bug to add a regression test.  The bug for fixing the code is bug 661563
Assignee: mbasta → kumar.mcmillan
Removing myself from a bunch of old AMO bugs
Assignee: kumar.mcmillan → nobody
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.