Video performance in Fennec has regressed in Firefox 6

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({mobile, perf, regression})

Trunk
ARM
Android
mobile, perf, regression

Details

(URL)

(Assignee)

Description

8 years ago
Steps to reproduce:
1. Open http://diveintohtml5.org/video.html in Fennec on Android
2. Scroll to the bottom of the page.
3. Play the HTML5 video.

In Firefox 4.0.1 and Firefox Beta 5.0b3 the video plays fairly smoothly.  In Aurora 6.0a2 and Nightly 7.0a1, the video is very jerky and not smooth at all (around 2 frames per second).

Tested on HTC T-Mobile G2 running stock Android 2.2 and Motorola Wi-Fi Xoom running stock Android 3.1.
(Assignee)

Comment 1

8 years ago
(In reply to comment #0)
> Tested on HTC T-Mobile G2 running stock Android 2.2 and Motorola Wi-Fi Xoom
> running stock Android 3.1.

Correction: I could *not* reproduce this regression on the Xoom.  Video performance on the Xoom was very bad in all versions of Firefox 4-7.
I've never had good html5 video playback on my G2.
tracking-fennec: ? → 6+
tracking-firefox6: ? → ---
(Assignee)

Comment 3

8 years ago
I can try bisecting nightlies next week.
Assignee: nobody → mbrubeck
I can reproduce on HTC Evo 4G, Android 2.3.3, Nightly 7.0a1
(Assignee)

Comment 5

8 years ago
I'm no longer certain this regressed from Fx5 -> 6.

When I tested this yesterday using the same device and same steps as comment 0, I saw the same bad performance in 4.0.1, 5.0b3, and 5.0b4 as in 6.0a2 and 7.0a1.  I tried each version at various zoom levels.  Despite trying repeatedly I could not get good performance in any version, though I had seen it work well before.  My laptop with the same wifi connection has no problems downloading and playing the video.

Meanwhile, http://random.pavlov.net/video.html (which is an Ogg Theora video with no audio) plays smoothly all the time on all versions I tested.
http://people.xiph.org/~tterribe/tmp/sintel_trailer_800x480.ogg should be the same video with sound. Does that still play smoothly? (I'm assuming silent2.ogg is still the http://people.xiph.org/~tterribe/tmp/sintel_trailer_800x480-nosound.ogg I encoded for stuart)
(Assignee)

Comment 7

8 years ago
(In reply to comment #6)
> http://people.xiph.org/~tterribe/tmp/sintel_trailer_800x480.ogg should be
> the same video with sound. Does that still play smoothly?

That video plays terribly (<1 fps) in Firefox 4 and Firefox 5.0b4 on my T-Mobile G2, while it plays almost acceptably (sometimes smooth, but with frequent dropped frames and audio stuttering) in Aurora 6 and Nightly 7.

I should note that I disabled Firefox Sync and closed all other activities while running all of the above tests.

Resolving this bug as WFM because it seems that my initial finding in comment 0 was incorrect.  There's still work to do on video perf, but this particular bug is not valid.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 8

8 years ago
For me the video: http://diveintohtml5.org/video.html is still not smooth at all. 
Does someone else experience this as well? Should I reopen the bug?

Build id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a2) Gecko/20110705 Firefox/6.0a2 Fennec/6.0a2 

Device: HTC Desire Z (Android 2.2)
(Assignee)

Comment 9

8 years ago
(In reply to comment #8)
> For me the video: http://diveintohtml5.org/video.html is still not smooth at
> all. 
> Does someone else experience this as well? Should I reopen the bug?

Reopen only if the performance has clearly regressed compared to a previous version. In my latest tests, performance is about the same in Firefox 4, 5, 6, and 7.
tracking-fennec: 6+ → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.