Closed Bug 661623 Opened 11 years ago Closed 11 years ago

Two kinds of missing MSAA focus events with iframe

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 618046

People

(Reporter: aaronlev, Unassigned)

References

(Blocks 1 open bug)

Details

#1: I'm not seeing MSAA focus events when I tab to an iframe document, either with MSAA Event Watcher or NVDA.

#2: The next focus event out of the iframe is also swallowed, if you reverse direction and go back to where you came from. It's as if we don't fire it because it looks redundant (it looks redundant because the iframe event didn't happen and we're back at the same place).

Sample page to test with:
http://www.w3schools.com/TAGS/tryit.asp?filename=tryhtml_iframe
Summary: Two kinds of missing MSAA focus events in iframe → Two kinds of missing MSAA focus events with iframe
#1: What version of Firefox? I definitely see focus events when tabbing into iframe documents in Firefox >= 4. I do remember this being broken in 3.6 after the first time you tabbed into the document; i.e. subsequent times would yield no focus event.

#2: This is a duplicate of bug 644455.
I don't see #1 on trunk as well, #2 is dupe of bug 644455 (or bug 618046).

Aaron, if you can reproduce #1 on recent releases then please reopen it.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618046
You need to log in before you can comment on or make changes to this bug.