File viewer URLs don't lead to where you would expect

VERIFIED FIXED in 6.1.1

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P3
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: jorgev, Assigned: Andy McKay)

Tracking

unspecified
6.1.1

Details

(Whiteboard: [ReviewTeam], URL)

(Reporter)

Description

7 years ago
If I'm looking at a file in an add-on, I have all the navigation items, diff indicators, etc. However, after selecting any of the files, the URL changes to something like https://addons.mozilla.org/en-US/firefox/files/compare/121428...120409/file/install.rdf#top
If I share this URL with someone, or even if I just reload the page, I lose all the navigation stuff and just get the raw file and the download options, which is not very useful.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 661912
(Assignee)

Updated

7 years ago
Assignee: nobody → amckay
Target Milestone: Q2 2011 → 6.1.1
(Assignee)

Comment 2

7 years ago
Split out file and fragment to keep the cache happy.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 3

7 years ago
linking to the exact file works now. verified fixed at https://addons-next.allizom.org/en-US/firefox/files/browse/120945/file/components/nsiMacros.js#top
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

7 years ago
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.