add w32-ix-slave{07,08} to production_config.py

RESOLVED FIXED

Status

Release Engineering
General
P3
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [slaveduty][badslave?])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
These hosts used to be staging, but have been re-imaged and there's no good reason to keep them in the staging pool.  They're already pointed at build hosts by slavealloc, and have the right SSH keys, but aren't in the production configs, it seems.  Please update and land the change.

Comment 1

7 years ago
Created attachment 537503 [details] [diff] [review]
as requested
Attachment #537503 - Flags: review?(dustin)
(Assignee)

Updated

7 years ago
Attachment #537503 - Flags: review?(dustin) → review+

Comment 2

7 years ago
Comment on attachment 537503 [details] [diff] [review]
as requested

http://hg.mozilla.org/build/buildbot-configs/rev/eb1eda45ddd6
Attachment #537503 - Flags: checked-in+

Updated

7 years ago
Assignee: nobody → aki

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

7 years ago
enabled and rebooted - these should be building soon.
Reopening, due to bug 656572 comment #3. I'm guessing the ref image is missing updates, and/or OPSI needs some packages marked for install. Disabled them both in slavealloc.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

7 years ago
Assignee: aki → nobody
Whiteboard: [buildmasters] → [slaveduty][badslave?]

Updated

7 years ago
Priority: -- → P3
(Assignee)

Updated

7 years ago
Assignee: nobody → dustin
(Assignee)

Comment 5

7 years ago
So far, affected are
 w32-ix-slave07 (bug 656572)
 w32-ix-slave08 (bug 656572)
 w32-ix-slave34 (bug 662853)
(Assignee)

Comment 6

7 years ago
So I think that this is caused by the use of a moving tag as the "version" for the buildbot package in OPSI.  the refimage has the old version in it, which is odd in itself, but since we don't specify a particular version, it doesn't even get updated.  I've updated the refimage, and will set the above w32-ix-* slaves to setup buildbot version BUILDBOT_PRODUCTION.  If that seems successful, I'll do the same for all w32-ix slaves, to catch any stragglers (since OPSI has no way to distinguish versions of buildbot).
(Assignee)

Comment 7

7 years ago
It was more complicated than that:
 w32-ix-slave07 was inventing the incorrect OPSI key for itself
 w32-ix-slave08 was pretty easy
 w32-ix-slave34 doesn't seem to have a good instal of mozillabuild, so I'm re-installing that, and it's taking forever.  So that's where we are.  None of the hosts are enabled yet, but 07 and 08 should be ready to go.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 8

7 years ago
w32-ix-slave{07,08} are doing fine, and have been rebooted back into action.

w32-ix-slave34 has been stuck since the 9th at the installing-MozillaBuild screen, and is now wedged.  I'll get a re-image started back on bug 662853.
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

7 years ago
07 and 08 are *not* fine - they do not have nagios installed.

I'm done with OPSI.  I'll install this package by hand.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

7 years ago
fixed with vim - they had an old version of NSC.ini.
(Assignee)

Comment 11

7 years ago
And fixed on the ref box, too.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 12

6 years ago
Many w32 ix machines have been having issues in the last few months. Several of them will be reimaged and setup correctly in bug 682408.
Blocks: 682408
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.