Intermittent timeout test_0083_error_patchApplyFailure_partial_complete.xul or test_0084_error_patchApplyFailure_verify_failed.xul | Test timed out. Maximum time allowed is 25 seconds

RESOLVED FIXED in mozilla7

Status

()

RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: masayuki, Assigned: rstrong)

Tracking

({intermittent-failure})

Trunk
mozilla7
x86_64
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

might be reated to bug 645607.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307091827.1307093164.25014.gz#err0

s: talos-r3-fed64-016
13314 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/mozapps/update/test/chrome/test_0083_error_patchApplyFailure_partial_complete.xul | Test timed out. Maximum time allowed is 25 seconds
13317 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/mozapps/update/test/chrome/test_0083_error_patchApplyFailure_partial_complete.xul | Checking if TESTS[2] test was performed... callback function name = defaultCallback, pageid = finished
13318 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/mozapps/update/test/chrome/test_0083_error_patchApplyFailure_partial_complete.xul | Found an existing Update Window from the current or a previous test... attempting to close it.
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
OS: Windows 7 → Linux
Hardware: x86 → x86_64
Component: General → Application Update
QA Contact: general → application.update

Updated

8 years ago
Blocks: 438871
Created attachment 537879 [details] [diff] [review]
patch rev1

This test never failed prior to changing the slow download interval from 1000 ms to 100 ms so I'm changing it back.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #537879 - Flags: review?(dtownsend)
Attachment #537879 - Flags: review?(dtownsend) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 6

8 years ago
Robert, can this land?
Yes, I plan on landing it today with a couple of other patches
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/399c2fef0673

Leaving open until this is verified to have fixed this orange

Comment 9

8 years ago
This also happened on test_0084_error_patchApplyFailure_verify_failed.xul, etc in http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307656910.1307658704.14651.gz (on a revision before comment 8)

Comment 10

8 years ago
Actually, what we usually do is close the orange bugs and later reopen them if they occur again.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(In reply to comment #9)
> This also happened on test_0084_error_patchApplyFailure_verify_failed.xul,
> etc in
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307656910.1307658704.
> 14651.gz (on a revision before comment 8)
Makes sense. Both tests require the download for the mar file to take longer than it takes to normally download the test mar file.
Summary: Intermittent timeout /test_0083_error_patchApplyFailure_partial_complete.xul | Test timed out. Maximum time allowed is 25 seconds → Intermittent timeout test_0083_error_patchApplyFailure_partial_complete.xul or test_0084_error_patchApplyFailure_verify_failed.xul | Test timed out. Maximum time allowed is 25 seconds
Still failing... will investigate further
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Backed out the patch since it didn't help and might have made things worse
http://hg.mozilla.org/mozilla-central/rev/9b43783ab8ec
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Well, this at least pointed out that something strange is going on in that the patch caused this to happen much more often when it shouldn't have. If anything, it should have had the opposite affect.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 538645 [details] [diff] [review]
patch

The reference to the timer appears to be getting lost... I verified this fixes this orange on Mac OS X.
Attachment #537879 - Attachment is obsolete: true
Attachment #538645 - Flags: review?(dtownsend)
Created attachment 538646 [details] [diff] [review]
patch - fix indentation
Attachment #538645 - Attachment is obsolete: true
Attachment #538645 - Flags: review?(dtownsend)
Attachment #538646 - Flags: review?(dtownsend)
Comment hidden (Treeherder Robot)

Comment 41

7 years ago
Oh, of course!  Another version of these issues.
Blocks: 640629

Updated

7 years ago
Attachment #538646 - Flags: review?(dtownsend) → review+

Comment 42

7 years ago
http://hg.mozilla.org/mozilla-central/rev/a7e6be787ed5

Thanks Robert for tracking this down!
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla7
Comment hidden (Treeherder Robot)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Not sure why this bug was reopened and I'm quite certain this specific bug was caused by the timer scope and that it is fixed. Please file a new bug if this test is failing.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
(In reply to Robert Strong [:rstrong] (do not email) from comment #44)
> Not sure why this bug was reopened and I'm quite certain this specific bug
> was caused by the timer scope and that it is fixed. Please file a new bug if
> this test is failing.

Because seemingly the same failure occurred again (see comment 43 and compare to the strings in previous comments).
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.