Closed Bug 661823 Opened 10 years ago Closed 10 years ago

Ctrl+F shouldn't work to open Find toolbar in about:permissions

Categories

(Toolkit :: Find Toolbar, defect)

10 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla7

People

(Reporter: mardeg, Unassigned)

References

Details

(Whiteboard: [testday-20110603][qa+])

Attachments

(1 file, 2 obsolete files)

In about:permissions the Find Toolbar is useless so it shouldn't be able to be opened, as is the case in about:addons
Also, using Ctrl F to close an already opened Find Toolbar in about:permissions should be able to close it, as is the case in about:addons
Whiteboard: [testday-20110603]
Summary: Ctrl F shouldn't work to open Find toolbar in about:preferences and should work to close existing Find bar → Ctrl F shouldn't work to open Find toolbar in about:permissions and should work to close existing Find bar
Blocks: 661831
Summary: Ctrl F shouldn't work to open Find toolbar in about:permissions and should work to close existing Find bar → Ctrl+F shouldn't work to open Find toolbar in about:permissions and should work to close existing Find bar
Attached patch patch (obsolete) — Splinter Review
This patch will make the find bar in about:permissions act the say way as in about:addons (bug 569342).
Assignee: nobody → margaret.leibovic
Status: NEW → ASSIGNED
Attachment #537223 - Flags: review?(gavin.sharp)
Comment on attachment 537223 [details] [diff] [review]
patch

Add a test to browser_zbug569342.js ?
Attachment #537223 - Flags: review?(gavin.sharp) → review+
(In reply to comment #0)
> Also, using Ctrl F to close an already opened Find Toolbar in
> about:permissions should be able to close it, as is the case in about:addons

This doesn't actually currently work in about:addons, AFAICT. That's bug 657500 - a solution there will likely fix this case too.
Attached patch patch with test (obsolete) — Splinter Review
Attachment #537223 - Attachment is obsolete: true
Attachment #537229 - Flags: review?(gavin.sharp)
Attachment #537229 - Attachment is obsolete: true
Attachment #537229 - Flags: review?(gavin.sharp)
Attachment #537244 - Flags: review?(gavin.sharp)
Comment on attachment 537244 [details] [diff] [review]
patch with refactored test

You could also move the removeTab() calls from the test* methods and move it into load() (in a registerCleanupFunction - it's OK that all the tabs stay open until the end of the test). That'd let you get rid of gTab.
Attachment #537244 - Flags: review?(gavin.sharp) → review+
Updating the summary to reflect what was actually done in this bug, even though I failed to do that for the commit message.

http://hg.mozilla.org/mozilla-central/rev/0c6e91c6f691
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Summary: Ctrl+F shouldn't work to open Find toolbar in about:permissions and should work to close existing Find bar → Ctrl+F shouldn't work to open Find toolbar in about:permissions
Target Milestone: --- → mozilla7
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
and
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110823 Firefox/9.0a1

Verified the CTRL+F functionality in about:permissions and about:addons pages and the behaviour is not the same nor the expected:
* about:permissions
  -> if find toolbar is not opened, it will open with CTRL+F
      Steps to reproduce:
      1. Launch firefox
      2. Go to about:permissions
      3. Press CTRL+F
      Result: find toolbar opens
  -> if find toolbaris opened, it will not close with CTRL+F
      Steps to reproduce:
      1. Launch firefox
      2. Press CTRL+F to launch the find toolbar
      3. Go to about:permissions
      4. Press CTRL+F
      Result: find toolbar remains open
  Note: there is a scenario when the find toolbar doesn't open in about:permissions page:
  Steps to reproduce:
  1. Go to about:permissions
  2. Open a new tab
  3. Go back to about:permissions page
  4. Press CTRL+F
  Result: Find toolbar doesn't open

* about:addons
  -> if find toolbar is not opened, it will not open with CTRL+F
      Steps to reproduce:
      1. Launch firefox
      2. Go to about:permissions
      3. Press CTRL+F
      Result: find toolbar doesn't open
  -> if find toolbaris opened, it will not close with CTRL+F
      Steps to reproduce:
      1. Launch firefox
      2. Press CTRL+F to launch the find toolbar
      3. Go to about:permissions
      4. Press CTRL+F
      Result: find toolbar remains open
Win7_64
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
and 
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a2) Gecko/20110825 Firefox/8.0a2

WinXP
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

Mac 10.6
Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0

Same behaviour as in comment 8
(In reply to Mihaela Velimiroviciu from comment #8)

> Verified the CTRL+F functionality in about:permissions and about:addons
> pages and the behaviour is not the same nor the expected:
> * about:permissions
>   -> if find toolbar is not opened, it will open with CTRL+F
>       Steps to reproduce:
>       1. Launch firefox
>       2. Go to about:permissions
>       3. Press CTRL+F
>       Result: find toolbar opens

This is not expected, and I'm not sure why it is different than about:addons. I think we should file a follow-up bug for this. This is especially odd given that the test should cover this.

>   -> if find toolbaris opened, it will not close with CTRL+F
>       Steps to reproduce:
>       1. Launch firefox
>       2. Press CTRL+F to launch the find toolbar
>       3. Go to about:permissions
>       4. Press CTRL+F
>       Result: find toolbar remains open

This is expected behavior. CTRL+F does not close the find bar on any webpage.

>   Note: there is a scenario when the find toolbar doesn't open in
> about:permissions page:
>   Steps to reproduce:
>   1. Go to about:permissions
>   2. Open a new tab
>   3. Go back to about:permissions page
>   4. Press CTRL+F
>   Result: Find toolbar doesn't open

This is expected behavior, and is what the patch in this bug implemented.

> * about:addons
>   -> if find toolbar is not opened, it will not open with CTRL+F
>       Steps to reproduce:
>       1. Launch firefox
>       2. Go to about:permissions
>       3. Press CTRL+F
>       Result: find toolbar doesn't open

This is expected behavior from bug 569342.

>   -> if find toolbaris opened, it will not close with CTRL+F
>       Steps to reproduce:
>       1. Launch firefox
>       2. Press CTRL+F to launch the find toolbar
>       3. Go to about:permissions
>       4. Press CTRL+F
>       Result: find toolbar remains open

This is expected, since as I said before, CTRL+F does not close the find bar on any webpage. I thought there was a bug filed once about how the bar should go away when you switch to a tab where it's supposed to be disabled, but I can't find it right now.
(In reply to Margaret Leibovic [:margaret] from comment #10)
> (In reply to Mihaela Velimiroviciu from comment #8)
> 
> > Verified the CTRL+F functionality in about:permissions and about:addons
> > pages and the behaviour is not the same nor the expected:
> > * about:permissions
> >   -> if find toolbar is not opened, it will open with CTRL+F
> >       Steps to reproduce:
> >       1. Launch firefox
> >       2. Go to about:permissions
> >       3. Press CTRL+F
> >       Result: find toolbar opens
> 
> This is not expected, and I'm not sure why it is different than
> about:addons. I think we should file a follow-up bug for this. This is
> especially odd given that the test should cover this.
> 
This is the same issue that this bug was initially logged for: CTRL+F opens the find toolbar in about:permissions although it shouldn't; hence reopening bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mihaela, was this ever working for you on a build since the check-in date of June 6th? If so, there could be a recent regression here. Please investigate in a new bug.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
I ran the scenario bellow on the following builds: Firefox 6.0(this is the first release that has the about:permissions page), Firefox 7 beta 5, latest Aurora and various Nighlies (some builds since June 4 to latest) and the issue described in this bug was reproducible: CTRL+F opens the find toolbar even though it shouldn't. I haven't found any build in which this issue was fixed (not reproducible).

Is it necessary to file a new bug? If I open a new one, which should be the status of this one (IMO this is not FIXED since the stated issue is reproducible)?

STR:
1. Launch Firefox
2. Go to about:permissions
3. Press CTRL+F

Result: Find toolbar opens.

Can this bug be reopened?

Thanks!
> Can this bug be reopened?
> 
> Thanks!

That is Margaret's call.
We can reopen this. I don't have time to dig into this problem right now, but we should make an additional patch to address the remaining issues.
Assignee: margaret.leibovic → nobody
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
QA needs to track this to verify it when fixed. Thanks Margaret and Mihaela.
Whiteboard: [testday-20110603] → [testday-20110603][qa+]
The patch here didn't get backed out, so we shouldn't track the followup issue here. Let's get a new bug on file.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Version: Trunk → 10 Branch
Blocks: 693029
Filed bug 661823
Sorry, confused myself, bug 693029 filed.
You need to log in before you can comment on or make changes to this bug.