Closed Bug 661863 Opened 9 years ago Closed 9 years ago

Problem with SVGs that pattern fill with a pattern from an Illustrator swatch.

Categories

(Core :: SVG, defect)

x86_64
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 633337

People

(Reporter: chuckseven1, Unassigned)

Details

(Keywords: testcase)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Pattern fills do not fill with the specified pattern and are instead just white.

Reproducible: Always

Steps to Reproduce:
1. Open an SVG that uses a swatch pattern made by Illustrator.

Actual Results:  
The filled area is just white.

Expected Results:  
The filled area should be filled with the pattern.
This SVG has a rectangle that is supposed to be filled with a pattern.
Component: General → SVG
Keywords: testcase
Product: Firefox → Core
QA Contact: general → general
This is the SVG viewed in Ubuntu Image Viewer, displaying correctly.
Attachment #537166 - Attachment mime type: application/octet-stream → image/svg+xml
chuckseven: Firefox's rendering looks fine to me -- it's just that you have to scroll right to see the patterned box.

This is because your SVG has width="132.73333cm" (over 4 feet) on its root node, with a viewBox/preserveAspectRatio configuration that asks for the box to be centered in that width.

If you scroll over (or just remove the bogusly huge width/height attrs on the <svg>) Firefox's rendering looks basically like your attached correct screenshot.
Here's the testcase again, but with the width & height attributes removed on the root SVG node (so they take their default values, "100%" [of the browser viewPort]")

This looks fine to me.

Unless I'm missing something, I think this bug can be RESOLVED|INVALID...?
This issue here is that the pattern is not rendered in the box.

Attached is screen shot of what I see with Firefox 4. This the same result is on Mac 10.5 and Ubuntu.

- Andrew
Attached image Firefox 4 Screen Shot
Ah, I see! Trying with Firefox 4 now, and I see what you mean.  (before, I was using today's nightly build, and it works there. :))

So, this is probably a duplicate of some existing bug -- whichever bug fixed this in nightly builds. :)

Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110602 Firefox/7.0a1
Indeed.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633337
You need to log in before you can comment on or make changes to this bug.