Last Comment Bug 661967 - GCC 4.6 build warning: "nsIOService.cpp:432:12: warning: variable ‘listedProtocol’ set but not used"
: GCC 4.6 build warning: "nsIOService.cpp:432:12: warning: variable ‘listedProt...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla7
Assigned To: Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
:
Mentors:
Depends on:
Blocks: 391978
  Show dependency treegraph
 
Reported: 2011-06-03 15:54 PDT by Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
Modified: 2011-06-08 14:57 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix: remove variable (1.24 KB, patch)
2011-06-03 15:57 PDT, Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
bzbarsky: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-03 15:54:15 PDT
When building with GCC 4.6:
{
netwerk/base/src/nsIOService.cpp:432:12: warning: variable ‘listedProtocol’ set but not used [-Wunused-but-set-variable]
}

From comparing these consecutive revisions...
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/netwerk/base/src/nsIOService.cpp&rev=1.199
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/netwerk/base/src/nsIOService.cpp&rev=1.200
...it looks like revision 200 (bug 391978) removed the last use of this variable.

Seems like we can just remove it completely now.
Comment 1 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-03 15:57:12 PDT
Created attachment 537258 [details] [diff] [review]
fix: remove variable
Comment 2 Boris Zbarsky [:bz] 2011-06-07 01:15:26 PDT
Comment on attachment 537258 [details] [diff] [review]
fix: remove variable

Oops.  The review comments in bug 391978 had even mentioned this....

r=me
Comment 3 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-07 10:52:51 PDT
http://hg.mozilla.org/projects/cedar/rev/d9c15147d35d
Comment 4 :Ehsan Akhgari (away Aug 1-5) 2011-06-08 14:57:45 PDT
http://hg.mozilla.org/mozilla-central/rev/d9c15147d35d

Note You need to log in before you can comment on or make changes to this bug.