If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fennec not installing on Tegras from Tracemonkey

VERIFIED FIXED

Status

Fennec Graveyard
General
P1
blocker
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aki, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

6 years ago
Bear, the ateam, and I have been spending a significant amount of the past week or more dealing with sharedID changes noted here:

http://mxr.mozilla.org/mozilla-central/source/embedding/android/Makefile.in#101

Per IRC, we decided to set the branding to nightly on all project branches and Try to try to get around not being able to install org.mozilla.fennec_unofficial on the Tegras as currently configured.  So we're currently assuming that mozilla-central, Try, and all project branches are 'org.mozilla.fennec'.

This doesn't seem to have solved things (Tracemonkey is fully red on Tegra runs).

So we need to:

a) figure out what sharedID / process name / directory name we need to be using here, because we've wasted serious amounts of time guessing wrong here, and

b) have some way to verify that that is the correct sharedID / process name / directory name.

From the binary, the only way I know to figure out the real directory/process name is to either install it or run 'strings' on libxul and grep for 'org\.mozilla\.f'.  This is not ideal.

If we can be guaranteed that this will be set per branch mozconfig and not change again in the future, then we can assume the process name and directory name by the branch we're building.
(Reporter)

Updated

6 years ago
Blocks: 661896
http://tbpl.mozilla.org/?tree=TraceMonkey&rev=7e6f3b179644&jobname=Android
(Reporter)

Updated

6 years ago
Severity: normal → blocker

Comment 2

6 years ago
i thought this was resolved last week.  is that not the case?
(Reporter)

Comment 3

6 years ago
It was busted Friday; looks good as of 1pm Sunday.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Um. On a single push on Sunday, I had to retrigger three builds before I got one that would install, it didn't look very good to me then. Even on Friday, it was not that case that _no_ Fennec builds would install, but that some would and some would not.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

6 years ago
(In reply to comment #4)
> Um. On a single push on Sunday, I had to retrigger three builds before I got
> one that would install, it didn't look very good to me then. Even on Friday,
> it was not that case that _no_ Fennec builds would install, but that some
> would and some would not.

Then our entire premise is wrong. If things are not signed properly or are not using the proper sharedID, then we wouldn't be able to install *at all*.  The fact that it's working sometimes and not others is very odd, and it makes it feel like we're just scratching the surface and quite possibly we may be trying to solve the wrong problem.
(Reporter)

Comment 6

6 years ago
Tegras aren't all permared on tracemonkey tree, which they would be if they couldn't install.
http://tinderbox.mozilla.org/showbuilds.cgi?tree=TraceMonkey
(Reporter)

Comment 7

6 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Um. On a single push on Sunday, I had to retrigger three builds before I got
> > one that would install, it didn't look very good to me then. Even on Friday,
> > it was not that case that _no_ Fennec builds would install, but that some
> > would and some would not.
> 
> Then our entire premise is wrong. If things are not signed properly or are
> not using the proper sharedID, then we wouldn't be able to install *at all*.
> The fact that it's working sometimes and not others is very odd, and it
> makes it feel like we're just scratching the surface and quite possibly we
> may be trying to solve the wrong problem.

Right.
If they're able to install some of the time, then we don't know what the problem is.  However, I have to go back to 1pm yesterday to see any red.
It's TraceMonkey; they don't work weekends.

The only thing that happened between last Friday and this morning was that I pushed two patches on Sunday, one of which got a build which installed the first try, and one of which got two builds which would not install, followed by one which would. Not counting nightlies, on Friday we had three usable builds and two unusable builds, on Sunday we had two usable builds and two unusable builds. No idea whether it's significant or coincidence that in that time, we've gotten three usable nightlies.
(Reporter)

Comment 9

6 years ago
Tracemonkey's pretty green post-clobbers.
(Reporter)

Comment 10

6 years ago
Pretty ready to call this fixed.
Philor?
Yup, it's not like I don't know how to reopen if I need to ;)
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 12

6 years ago
Can someone please verify this ?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.