Provide an Image AUTO-Rotation Functionality

VERIFIED DUPLICATE of bug 298619

Status

--
enhancement
VERIFIED DUPLICATE of bug 298619
8 years ago
6 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: TB 5.0b2pre (on Win7, 64-bit)

When you receive a message with
- an embedded image or
- an attached image that it displayed inline (TB -> View -> Display attachment inline)
there's currently no way to make TB AUTOMATICALLY rotate that image, so that it is displayed in the right direction/orientation.

Reproducible: Always

Comment 1

8 years ago
If you're talking about using the EXIF flag, which can be found in a JPEG file, it's bug 298619.

Otherwise, I don't know what you mean with 'automatic rotation'. If you mean that you can rotate the image using a context menu (or icon or keypress), then it would be a *manual* rotation. There's a bug about it somewhere, but I can't find it.
(Reporter)

Comment 2

8 years ago
To be honest, I don't understand bug 298619 (EXIF). But maybe it's the same.
I'll create an attachment with an example to make things clear.
(Reporter)

Comment 3

8 years ago
Created attachment 537348 [details]
Screenshot_Example_Auto-Rotation

Comment 4

8 years ago
EXIF is a special flag that can be present in some JPEG images (especially when taken by professional cameras), that indicates if the camera was held sideways when the photo was taken. Bug 298619 would recognize such phots and rotate the image automatically. Photos without the flag would do this though.

But that the only *automatic* rotation that can be performed - how would you know what side is up ? The image is displayed sideways, because that's how it was inserted int he mail in the first place.

A button somewhere in the Thunderbird UI to rotate the image manually, would be very useful though.
(Reporter)

Comment 5

8 years ago
Thanks for the explanations.
Then it's clear, my bug report here is a dup of bug 298619.

PS:
The manual rotation is Bug 624330.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 298619
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.