-moz-appearance: radio-small is not supported, though listed in the MDC docs

RESOLVED FIXED

Status

Developer Documentation
General
--
minor
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Andreas Eibach, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110517 Firefox/6.0a1
Build Identifier: 

-moz-appearance: radio works in CSS code, but -moz-appearance: radio-small does NOT. Though not the end of the world, it ought to be marked as not supported by current Gecko engine.

Reproducible: Always

Steps to Reproduce:
Use this code in a test page:

button[type="radio"]
{
  -moz-appearance: radio-small !important;
}

Actual Results:  
Error console shows:

"Error parsing value in -moz-appearance. Declaration dropped."

Expected Results:  
..

As described above, it's not the end of the world if this function is missing. But as we've been lacking a *DECENT* XUL book for years and this on-line source is the only "documentation" we have (which, btw, requires us to be permanently on-line, even if there actually was no need with a specific add-on), this is *THE* reference for everyone.

So if there is no information that a -moz-appearance property is not supported, it will be assumed as supported by said "everyone."
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Summary: -moz-appearance: radio-small is not supported, albeit listed in the MDC docs → -moz-appearance: radio-small is not supported, though listed in the MDC docs

Comment 1

7 years ago
It was removed in bug 459708, but the documentation was never updated.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: XP Toolkit/Widgets: XUL → Documentation Requests
Product: Core → Mozilla Developer Network
QA Contact: xptoolkit.xul → doc-request
Resolution: --- → FIXED
Version: Trunk → unspecified
(Reporter)

Comment 2

7 years ago
Obviously.

Thanks.
(Reporter)

Comment 3

7 years ago
...However, you guys were a bit quick with your R/F, as it's NOT "obsolete".

Obsolete means it may be used, but it has no effect. Or obsolete means the same as the buzzword "deprecated" from the JAVA world, i. e. that it's likely to get unsupported sooner or later.

However, here it will downright *provoke an error*, that's something else. That's not obsolete, but *unsupported*, *no longer available*.

In my German mother tongue, obsolete would be translated as "veraltet" (to have become too old). However, if you use some obsolete fuse type in your fuse box, it may not comply with the current technological standards, BUT YET IT MAY WORK FINE ANYWAY.

But "-moz-appearance: radio-small" simply does not work, as it's unsupported.
Two pairs of socks. :)
(In reply to comment #3)
> ...However, you guys were a bit quick with your R/F, as it's NOT "obsolete".
> 
> Obsolete means it may be used, but it has no effect. Or obsolete means the
> same as the buzzword "deprecated" from the JAVA world, i. e. that it's
> likely to get unsupported sooner or later.
> 
> However, here it will downright *provoke an error*, that's something else.
> That's not obsolete, but *unsupported*, *no longer available*.

You are incorrect; in our documentation, "deprecated" means it still exists but should not be used because it will be removed soon. "Obsolete" means it no longer functions.
(Reporter)

Comment 5

7 years ago
?!
Great, then it was a bad thought to have tried to derive the meaning of the word "obsolete" from everyday language. Because that's what I did.
Again: an obsolete fuse type WILL most likely work in your fuse box! Just when an electrician comes along, he may tell you that you're no longer _allowed_ to use that type of fuse. But because of that, it doesn't imply that it'd stop working ;)

Oddly enough, the Microsoft definition would be analogue to yours, though. (What a great coincidence for the MF! lol) Since this company is known to declare certain features as "obsolete" which are in fact _artificially_ blocked by code, thus effectively not working; though possible to get re-enabled just by removing said artificial barrier.
Our usage of "obsolete" versus "deprecated" is standard. Your interpretation differs from every definition I've ever heard of before. Just FYI. :)
(Assignee)

Updated

5 years ago
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.