Execute: Calling this method crashes (2 parameter form)

RESOLVED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
RESOLVED WORKSFORME
19 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: Sean Su)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: 5/17/99 SeaMonkey build

1. Use jar at http://jimbob/jars/a_execute_parameter.jar
2. Using form, Install.Execute("notepad.exe", "smrtupdt.txt");
3. Trigger jar

RESULT:
SeaMonkey crashes.  Install.log shows:
---------------------------------------------------------------------------
Acceptance: a_execute_parameter
---------------------------------------------------------------------------

     Starting Installation at 05/17/1999 14:52:55

EXPECTED RESULT:
The executable, "notepad.exe", is launched and opens the text file,
"smrtupd.txt".  The Install.log shows that method was successfully executed.
(Reporter)

Updated

19 years ago
QA Contact: 4395 → 4138
(Reporter)

Comment 1

19 years ago
Changing QA Contact from Grace to Jimmy.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
fix with bug 6620.

*** This bug has been marked as a duplicate of 6620 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

19 years ago
Build 6/1/99 Windows

I am still getting a quick crash with this jar.  Bug 6620 worked for me.  My
assumption is that there may be another problem.  The Install.log shows no jar
triggered.  So in a way, the problem may be worse now since before the jar
started to write to the Install.log.

Once difference is that I am testing this on Windows 98.  My Windows NT is down
and out for now until I get some repair work done.

Comment 4

19 years ago
Clearing resolution.  jimmylee, we need a Talkback stack trace on this. I do not
find any talkback reports from you logged. Can you make one for this and paste
in stack trace ASP please?

Updated

19 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

19 years ago
Build: 6/7/99 Windows NT

Stack Trace:

[   0] A8 FE 12 00 01 E6 7E 00                         [......~.]

Talkback report has been sent as well.
(Reporter)

Comment 6

19 years ago
Build: 6/7/99 Windows NT
Incident ID: 9608381

Call Stack:    (Signature = MSVCRT.dll + 0x2ca70 (0x7802ca70) 32fcf9e4)
   MSVCRT.dll + 0x2ca70 (0x7802ca70)
   xpcom.dll + 0x4734 (0x10004734)
   xpcom.dll + 0x1a2a2 (0x1001a2a2)
   xpcom.dll + 0x1b2d5 (0x1001b2d5)

Here's the real deal.  Technical difficulties earlier.

Updated

19 years ago
Assignee: dougt → ssu
Status: REOPENED → NEW
Target Milestone: M8

Comment 7

19 years ago
setting target milestone to M8
reassign to ssu
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → REMIND
(Assignee)

Comment 8

19 years ago
I can't reproduce the crash.  Perhaps Jimmy has an unstable build of seamonkey?

I'm going to mark this as REMIND.  I would like to try to reproduce this bug on
the M7 build when it comes out.  If REMIND is not the correct resolution, please
change to the appropriate one.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
Build 8/27/99

Cannot reproduce crash.  Marking Verified.  This test case is part of
XPInstall Acceptance Suite, so if the problem returns a new bug will be
submitted.

Comment 10

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
REMIND is deprecated per bug 35839. I assume this bug is INVALID due to the code
dying, but I can't figure out what it applies to.
Status: VERIFIED → REOPENED
Resolution: REMIND → ---

Comment 12

14 years ago
WFM per comments above.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.