All Themes, treecell headers don't depress when clicked

VERIFIED FIXED in mozilla0.8

Status

P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: hewitt, Assigned: hewitt)

Tracking

Trunk
mozilla0.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

18 years ago
When you mouse down on a treecell header, since it looks like a button it should
behave like a button.  I have already got a fix for this on windows classic.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
(Assignee)

Updated

18 years ago
Keywords: nsbeta1
Priority: P3 → P2
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 1

18 years ago
Some notes about the patch I'm about to submit:

In addition to making treecell headers clickable, I had to make some other
changes around the theme to adjust to the new headers.  Specifically, I changed
the way tree focus rings look in messenger, and tweaked treerow focus borders
and removed some crud from editor.  The forthcoming patch fixes both modern and
classic win.
(Assignee)

Comment 2

18 years ago
Created attachment 23788 [details] [diff] [review]
patch to fix
(Assignee)

Updated

18 years ago
Keywords: review

Comment 3

18 years ago
This patch can't go in (as is) until the patch for bug 57429 is checked in.

I need to take a closer look (maybe later), but one thing which stood out was
this:

+tree:focus > treechildren treeitem[selected="true"][current="true"] > treerow,
+tree:focus > treechildren treeitem[selected="true"][current="true"] > treerow >
treecell {

Do you need the descendant selector here or could you get away with some child
selectors?
Depends on: 57429
(Assignee)

Comment 4

18 years ago
You're right -- those descendant selectors are nasty.  They have been there
since before we shipped NS6.  The problem is that only the tree receives focus,
not individual treerows.  If we want to optimize this, we should write some code
in the tree xbl binding which marks the selected rows with a "focused" attribute
whenever the tree is focused.

I'll file that issue as a separate bug -- for now, let those descendant
selectors stay in there, they are needed because treeitems can be nested at any
depth within trees.

Comment 5

18 years ago
Why does modern need its own tree header XBL bindings?  Would these be more
appropriately placed in treeBindings.xml where all skins could use them, or are
they really skin specific?
(Assignee)

Comment 6

18 years ago
You're right, I should probably put those in treeBindings.xml.  The reason I did
it that way is because I simply copied those bindings from the classic skin, but
they should probably be dumped from classic and shared.  Will submit adjusted
patch shortly.
Actually classic needs its own content bindings at least because classic 
treeheaders have multilevel borders, at least on Windows. 
(unless you plan to have an extra box in the global binding as well)
(Assignee)

Comment 9

18 years ago
Might as well have the extra box in the global content binding.  All of our
skins now use it, and it's one less thing for a theme author to have to worry
about. I'm also moving the treecell-header-image binding into
global/content/treeBindings.xml
(Assignee)

Comment 10

18 years ago
Created attachment 23928 [details] [diff] [review]
patch to fix (rev2)
(Assignee)

Comment 12

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Keywords: review
Resolution: --- → FIXED

Comment 13

18 years ago
Marking verified (2001-02-21-04-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.