When expanding FTP trees deep, memory consumption reaches 100% and slows down the Win OS

VERIFIED DUPLICATE of bug 65220

Status

()

Core
Networking: FTP
--
critical
VERIFIED DUPLICATE of bug 65220
18 years ago
16 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: dougt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
** Observed with 1/22/2001 Win32 build **

This proble has been going on for some time now.
The above build simply means that the problem
is still reproiducible with the current build.
This problem is so noticeable that I hope someone
is already working on it.

I am not sure if this is a layout a problem but I don't know
exactly where to place this bug. Here's the problem description,
when I try to download Netscape internal build installer and
when Mozilla remembers where I last visited on that FTP server,
it tries to expand the directory tree all the way down to 
something like:

ftp://hostname/directory1/directory2/seamonkey/windows/32bit/x86/

The last directory, 'x86', contains masny builds from the present
and past dates. 

Now as the above build tries to expand all the directory
structures, memory consumption on my Windows NT4 (US & Japanese)
reaches 100% and slows down everything until this process is
terminated. There is no way to do anything else once this state
is reached, and it happens every time the FTP directory structure
is expanded.
I have a 500Mhz processor and 256MG RAM and so this is quite
a consumption.
(Reporter)

Comment 1

18 years ago
Maybe waterson or mscott has heard about this problem.
(Reporter)

Comment 2

18 years ago
Added mcafee to the CC list. This bug needs the right component
to go to.

Comment 3

18 years ago
Doug, I started noticing this problem at the same time that big ftp landing
happened the other week. I suspect you might be the best person to look into this.

re-assigning.
Assignee: clayton → dougt
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

18 years ago
yup.  this was caused my me.  I am working of broad changes to necko which will
inturn fix this problem.

*** This bug has been marked as a duplicate of 65220 ***

Comment 5

16 years ago
VERIFIED: same problem.
Status: RESOLVED → VERIFIED
Component: Layout → Networking: FTP
QA Contact: petersen → benc
You need to log in before you can comment on or make changes to this bug.