Sometimes the charset for a mail inherits the charset of previously selected mail

VERIFIED FIXED in mozilla0.8

Status

VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

({intl})

Trunk
mozilla0.8
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
***observed with 2001-01-19-06-mtrunk win32 build*****
Sometimes, the charset for a mail doesn't have its own charset marked on the
charset menu, it has the charset of previously selected mail marked.

Steps to reproduce:
1. Download and unzip the smoketest folder on the above URL.
2. Have a mail that has incorrect charset info in the body. I'll attach the mail
later. This mail has iso-2022-jp contents, but incorrectly labeled as iso-8859-1.
3. Select the incorrectly labeled mail first, select View | Character Encoding
menu, you'll see Western (iso-8859-1) is marked on the left.
4. Go to the smoketest folder, select 2nd mail, which is an iso-2022-jp mail.
Select View | Character Encoding menu, you'll see
Japanese (iso-2022-jp) is marked for this mail.
5. Go back to the incorrectly labeled mail, select View | Character Encoding
menu, you'll see the charset marked for the mail doesn't change to iso-8859-1,
it stays as iso-2022-jp.
It doesn't looks like a cache problem,  since at Step 4, the 2nd mail in the
smoketest folder has correct charset marked even you select  the incorrect
labeled mail first.
(Reporter)

Comment 1

18 years ago
Created attachment 23207 [details]
ISO-2022-JP message incorrectly labeled as ISO-8859-1

Comment 2

18 years ago
i think this is the case of cache update that was raised in # 61285
(Reporter)

Comment 3

18 years ago
I wonder if it's a cache problem, why it can always have right charset marked 
for the mails in the smoketest folder.
(Reporter)

Comment 4

18 years ago
Added intl keyword.
Keywords: intl
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8

Comment 5

18 years ago
messages in smoketest folder ( smoketest.zip) are MIME encoded, messages that
inherit the previous charset has no MIME info.
(Reporter)

Comment 6

18 years ago
The testcase I attached has wrong MIME charset info. 

Comment 7

18 years ago
right, that's why it never happens in the smoketest folder where the MIME label
is correct
(Assignee)

Comment 8

18 years ago
I think this is fixed now, I cannot reproduce it with today's build (win32 id
2001020504).
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

18 years ago
Verified with 04/02 build. 
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.