If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Normal -> Source mode causes change [Save state] even with no changes

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.2
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
found this using a recent debug [this afternoon] linux mozilla build. sujay,
does this occur on all platforms?

to repro:
1. open a web page in composer. any will do. by default you'll be in Normal view
mode.

2. don't make any changes to the document. now, go into HTML Source mode. [what
i did was select/turn on View > Toolbars > Edit Mode toolbar, then clicked the
HTML Source tab.]

observe: the Save button, while in Source mode, becomes active --as if a change
had been made. but nothing has [fwiw, i don't see the appended <br>'s bug
here... cannot recall the bug # for that, though].

expected: if no changes are made, Save shouldn't be required --or, at the very
least the UI should reflect this.
(Assignee)

Comment 1

17 years ago
Sorry, but we can't support this with current architecture. HTML Source is a
simple kludge and to allow Save to work at all, it has to be forced enabled even
if no change is made.
This and many other inconveniences about HTML Source will disappear when we can
support multiple editors per document and we implement a full Text Editor that
can have better command enabling.
 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

17 years ago
Perhaps there's a sneaky way to do it if someone wants to work on it -- taking
the liberty of marking this helpwanted (hope Charley doesn't mind).
Keywords: helpwanted
(Assignee)

Comment 3

17 years ago
*** Bug 66337 has been marked as a duplicate of this bug. ***
Is there a bug on the "multiple editors per document"?
(Assignee)

Comment 5

17 years ago
Bug 66296.
(Assignee)

Comment 6

17 years ago
This is fixed by fix to bug 81227. Cause is same, so we might as well dup it.

*** This bug has been marked as a duplicate of 81227 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

17 years ago
Changed my mind -- make dependency instead of duping.
Status: RESOLVED → REOPENED
Depends on: 81227
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

17 years ago
Fix is attached to bug 81227
r=mjudge, sr=kin
Status: REOPENED → ASSIGNED
Keywords: helpwanted
Whiteboard: FIX IN HAND
Target Milestone: Future → mozilla0.9.2
(Assignee)

Comment 9

17 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Whiteboard: FIX IN HAND

Comment 10

17 years ago
no longer does the 'save' button highlight when switched to 'html source' mode.
verif in 0618 trunk linux
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.