Crash at CheckStackAndEnterMethodJIT

RESOLVED DUPLICATE of bug 595351

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 595351
7 years ago
7 years ago

People

(Reporter: Herbie D, Unassigned)

Tracking

({crash, regression})

2.0 Branch
x86
Windows NT
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

2nd crash in less than 24 hours for same problem. Also, the last 9 crashes have been prefaced by -bp.

Reproducible: Sometimes

Steps to Reproduce:
1.Last 2 Crash Reports
2.
3.



Seems to be related to the JIT compiler and Javascript libraries.

0|1|mozjs.dll|CheckStackAndEnterMethodJIT|hg:hg.mozilla.org/releases/mozilla-2.0:js/src/methodjit/MethodJIT.cpp:fca718600ca0|778|0x23

Comment 1

7 years ago
Please go to about:crashes and paste links to the relevant crash reports here.
Assignee: nobody → general
Component: Page Info → JavaScript Engine
Keywords: crash, stackwanted
Product: Firefox → Core
QA Contact: page.info → general
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Please go to about:crashes and paste links to the relevant crash reports
> here.

https://crash-stats.mozilla.com/report/index/bp-4a0b4b67-6c57-4845-8328-6d4142110607

Comment 3

7 years ago
Setting dependency on Bug 595351
Blocks: 595351
Crash Signature: [@CheckStackAndEnterMethodJIT]
Keywords: stackwanted → regression
Summary: CheckStackAndEnterMethodJIT → Crash at CheckStackAndEnterMethodJIT

Comment 4

7 years ago
Without STR, this bug is considered as a dupe of bug 595351.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595351

Comment 5

7 years ago
Bug 595351 is a metabug
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 6

7 years ago
(In reply to comment #5)
> Bug 595351 is a metabug
The goal of a crash metabug is to track different causes per depending bug. What is the test case for this bug?

Comment 7

7 years ago
> The goal of a crash metabug is to track different causes per depending bug.
Ah perhaps someone can update <https://bugzilla.mozilla.org/describekeywords.cgi#meta> because your use of meta isn't documented there.

> What is the test case for this bug?
No idea. I'm just helping out with triage.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595351

Comment 8

7 years ago
In the future, for bugs related to crashes, please use the [@ CrashSignature ] syntax in the summary so that it can be tracked in Socorro. For instance, see the "Bugzilla Ids" column in:
https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/4.0.1

Bugs related to crashes are classified as critical.
No longer blocks: 595351
Severity: normal → critical

Comment 9

7 years ago
Any time now server ops will be running a script to remove crash signatures from bug summaries. They are now supposed to go into the new crash signature field.
You need to log in before you can comment on or make changes to this bug.