firefox 4 sync no longer works - bookmarks from ff3.6 have got corrupt

RESOLVED INCOMPLETE

Status

Cloud Services
Firefox Sync: Backend
--
critical
RESOLVED INCOMPLETE
7 years ago
7 years ago

People

(Reporter: andE Rigby, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

144.19 KB, text/plain
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Hi
with firefox 3.6 I had 3 systems (2* linux, 1* windows XP) syncing bookmarks and history using the sync addon. It worked fine.
As I upgraded each of my boxes to firefox 4, keeping the same sync account I began to notice that each of my updated boxes having a problem with sync (error message at the bottom of browser window - sync now never resolved the problem.
Tried removing and readding device.
Now I notice that my bookmarks seem to be generally screwed up everywhere.
Can I retrieve the original bookmarks from 3.6 anywhere? Is this a known bug I could not find it.
I did a log of the sync and the issue seems to be with bookmarks.

Reproducible: Always

Steps to Reproduce:
1.have sync addon setup on ff3.6 from multiple devices
2.upgrade to ff4
3.sync

Actual Results:  
I seem only to be able to sync history and not bookmarks.
bookmarks are now corrupt on each of my systems.
i.e. if I deactivate bookmark sync the error vanishes BUT my bookmarks are lost :-(

Expected Results:  
I would expect to not lose my data.
Thanks for any help!

Here is an extract of the log: the first line was reproduced OFTEN throughout the log:
1307442254594	Engine.Bookmarks	WARN	Error decrypting record: Record SHA256 HMAC mismatch: should be 8b1113387b3e5798b352da01ed4d016860e6a16d0ea0e1dc8ad5c0763326c8f8, is 65b2abf55a252823e3bfa799b2b2227c71fb8203c0e2bab95b1081c30fa95f5b No traceback available
1307442254596	Collection	DEBUG	GET success 200 https://phx-sync010.services.mozilla.com/1.0/anderigs/storage/bookmarks?full=1&ids=-kFBxeAVluPD,0KX5BatD82ZJ,0wAN6xwZemDf,0wIzc9keRyKX,1JVTE3Q9r7hb,1ON07kYpOovQ,1_et6NQaXpp-,289fq4mJ-k…
1307442254598	Engine.Bookmarks	DEBUG	Records that failed to apply: -kFBxeAVluPD,0KX5BatD82ZJ,0wAN6xwZemDf,0wIzc9keRyKX,1JVTE3Q9r7hb,1ON07kYpOovQ,1_et6NQaXpp-,289fq4mJ-kJJ,2DJn-eUpcfWh,3aWvPLYi0xuI,3exwsYBAo2ze,3j4MfsspYVGE,3op16PacWn6t,3sXr0JE431cM,4-nBtzUARjsI,41tLqdgPbULb,4OYbQgY_MmVV,4TI_hsOvFBhP,4WD56liG8V6i,4o3TruzgUNvi,4oqckhtAq7PY,4pr26ZdiXPVA,4sxh4cskYvTz,5KJW78PmvBJQ,5NLLX9rneJh6,5TlRfxJVeAX0,5U8z_eKmUnN3,5c1f5R90kuUu,5hWS8WScxUJw,5iTXXfseZcq-,69gXGLxyDPMz,6CJM5hsk5whd,6EJomyakQh-x,6GZVtDT9XcQo,6O4k9mlkUlvo,6SxuAZKqG83E,6X8PPrrtm0Mh,6e-YJ-abvjir,6gZ_z4CKnh1O,6gq4OtYNbkan,7GD3y9pE8yR5,7JGeMuJ-V_nD,7ZAHoEAf4E2h,8afn3E14Iv9B,8clfvI3dWjIH,8h1fUAIMi-5A,8yzNxL7_QzkS,9-vyDTVYSqVy,9HXkdCkNTWP_,9VSD7DZjqBDL,9v3diBopYAOa,9yfqVS45o-ly,9z73-uG8vb3o,A6Xy6Ok26Mbc,AA14SDKLTlWQ,A_nHAADN3QuU,B0Dii5F0crfa,B9wu7cVYllow,BAO9jZhnBt6c,BAursTy8WW0R,BB0Py5-4nN6R,BHCvUuF4kJwx,BYXxVAPXnyG4,BmRTe8Cf7f_U,Bnv8wGa8qnA8,Bog5HH7itJin,BqWIHfazOnz4,C8KvqcYEj6ab,CoZA3qXb3PX3,Ct91obNJk4h6,D6XwGDtvB4VG,DaW7uGdTETpC,DvYIZnnHZBZ2,EInLS9QxCJT2,Ea_p8bVt1R2o,F3nQLIiVYuZC,FiRJEpOyG_Bu,GBqnfjrnvUco,Gjj0YeoeQDte,J9v_3vW0MQ9Y,JWWkrgRWSHtn,JjfoLj-HFpF8
1307442254599	Service.Main	DEBUG	bookmarks failed to apply some records.
1307442254600	Engine.Bookmarks	INFO	Records: 0 applied, 82 failed to apply, 0 reconciled.
1307442254628	Engine.Passwords	INFO	0 outgoing items pre-reconciliation
1307442254630	Engine.Passwords	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1307442254658	Service.Main	DEBUG	Exception: Some engines did not sync correctly No traceback available
Component: General → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: general → sync-backend
Something went wrong with key management, and one of your systems uploaded some bookmark records that were encrypted with the wrong key. The error you're seeing is Sync refusing to apply those records, because it can't verify the record.

The root cause is elusive, but the bug that's indicated in your log shouldn't have any effect on bookmarks that already exist on your various browsers.

It would help to know what you mean by "generally screwed up", and which version of the Sync addon you were using. The entire contents of about:sync-log and about:sync-log.1, *attached* to this bug (not pasted into the comment field), might shed some light on this.

The easiest solution to this problem is to generate a new sync key, and enter it on each machine. Open Preferences, go to the Sync tab, choose "My Sync Key", and click "Generate". Enter the resulting key on the other two machines when prompted.
Blocks: 646269
(Reporter)

Comment 2

7 years ago
Created attachment 537880 [details]
sync.log
(Reporter)

Comment 3

7 years ago
Hi
thanks for the fast response. I cannot find about:sync-log.1.
I am not sure which version of sync addon I was using but I moved to ff4 as soon as it became officially released. And until then had always taken the automatic updates to the sync addon within ff3.6.
What I meant with screwed up bookmarks is that I had had three separate sets of bookmarks two on personal systems and one on work and was intending to merge them with the sync.
Well, now I have some kind of mini subset which seems to be propogated to all systems now with LOADS of bookmarks missing - like 90% missing. Is there anyway to get them back from anywhere? This is actually my biggest issue right now. 
Thanks for the ideas with the generating a new sync key.
Firefox creates daily bookmark backups: http://support.mozilla.com/en-US/kb/Lost%20Bookmarks#w_restoring-bookmark-backups which should restore and then sync an older copy of your bookmarks.
(Reporter)

Comment 5

7 years ago
thanks Mike.
I just restored a set of bookmarks and have an idea based on this experience.
My work windows PC is setup for german DE locale. My two personal linux PCs are setup for english UK locale.
when I imported my bookmarks it imported them not in the bookmarks folder but in the german "lesezeichen" folder.
Not sure if this causes the issue... as I guess this could cause confusion ...
cheers
andE

Comment 6

7 years ago
The same for me but I'm not sure is a locale issue.
It has worked for several months without problem with my 3 laptops + 2 mobiles, then after upgrading linux firefox client,the problem has begun

Comment 7

7 years ago
meta bug tracked in bug 646269
Status: UNCONFIRMED → NEW
Ever confirmed: true
Closing old HMAC bugs after remediation. Reporter, please reopen if you've had this reoccur after some time after successfully using Firefox 7 or later on all of your devices.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.