Split -no-remote option into -no-local and -no-remote options

RESOLVED WONTFIX

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.19) Gecko/20110430 Iceweasel/3.5.19 (like Firefox/3.5.19)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.19) Gecko/20110430 Iceweasel/3.5.19 (like Firefox/3.5.19)

This is a followup of bug 346198.

The firefox command currently has the following option:

  -no-remote     Open new instance, not a new window in running instance.

(which is a bit ambiguous because it doesn't say where the running instance can be found, and how profiles have an effect on it). However the user may want something more flexible: connect to a running instance only when it is on the local machine. The reason is to be able to use the file:/// URL's or other features (e.g. IP-based permissions and/or proxy settings may be different on the remote machine). IMHO, the -no-remote option should do that.

And there should be a new -no-local option that has the current -no-remote behavior.

Reproducible: Always

Steps to Reproduce:
1. n/a

Comment 1

7 years ago
The complexity here is not worth the gain, especially because of the different implementations on different platforms.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 2

7 years ago
For the benefit of removing ambiguity I quote Benjamin from bug 441422 comment 1 for clarification:
"-no-remote is specifically for not integrating with the OS *and* links from external apps are specifically integration with the OS."

It seems using file:/// URL's counts as "links from external apps"
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> It seems using file:/// URL's counts as "links from external apps"

file:/// URL's can also be used directly from the command line (anyway, one can see the shell as an external app).

But then, since -no-remote cannot be used (well, once is OK, but not twice due to bug 135137), how can one open such file:/// URL's that are on a remote machine (but local to the firefox command)?
You need to log in before you can comment on or make changes to this bug.