Send mail to jetpack developers


Status Graveyard
Admin/Editor Tools
7 years ago
2 years ago


(Reporter: clouserw, Assigned: jbalogh)






7 years ago
Sorry for the late-breaking bug.  This spawned from our discussion on IRC not to upgrade add-ons with <1.0 SDK.  Instead, we want to email the authors with a short message about the new release.

Text to be delivered shortly (dbuc is writing it)

One email per developer, even if they have multiple add-ons.

Thanks.  P1 in this milestone because we gotta do this the week of the 20th

Comment 1

7 years ago
Content for the email:


Hello Mozilla Add-ons Developer!

With the final version of the Add-on SDK only a week away, we wanted to get in touch with all add-on developers who have existing SDK-based (Jetpack) add-ons. We would like you to know that going forward AMO will be auto-updating add-ons with new versions of the Add-on SDK upon release.

To  ensure that your add-on(s) are auto-updated with the 1.0 final version of the SDK, we would ask that you download the latest release candidate build -, - and update your add-on(s) on AMO. After the 1.0 release, we will scan our add-ons database and automatically upgrade any SDK-based add-ons we find that are using verions 1.0RC2 or greater to the 1.0 final version of the SDK. Any add-ons we find using  versions of the SDK below 1.0RC2 will not be auto-updated and you will need to upgrade them to the 1.0 version of the SDK manually.

Thank you for participating in the early stages of the Add-on SDK’s development. Feedback and engagement from developers like you are the foundations for success in our open source community!


- Mozilla Add-ons Team

Comment 3

7 years ago
Does this email come with a subject?

Comment 4

7 years ago, I made this up:

SUBJECT = 'Automatic Jetpack Upgrades'
Last Resolved: 7 years ago
Resolution: --- → FIXED
Sorry Jeff just saw this. Is there any way we can go with - "Instructions for Automatic Upgrade to Add-on SDK 1.0" - or is it too late?

Comment 6

7 years ago
(In reply to comment #5)
> Sorry Jeff just saw this. Is there any way we can go with - "Instructions
> for Automatic Upgrade to Add-on SDK 1.0" - or is it too late?

That's the subject now.
Product: → Graveyard
You need to log in before you can comment on or make changes to this bug.