Screenshots bloat the SDK

RESOLVED FIXED

Status

Add-on SDK
Documentation
P3
enhancement
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: wbamberg, Assigned: wbamberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Those screenshot PNGs increase the size of the SDK download quite drastically. We should investigate compressing them.
OS: Mac OS X → All
Priority: -- → P2
Hardware: x86 → All
Target Milestone: --- → 1.0
Duplicate of this bug: 662630
(automatic reprioritization of 1.0 bugs)
Priority: P2 → P1
Target Milestone: 1.0 → 1.1
FYI, I get about a 10% space savings by just opening the PNGs in Gimp and re-saving. The random-noise background on the "default-panel-OSNAME.png" is hard to compress: could we use a more-boring (and more-compressible) background without making it hard to tell which part is the panel? For space-saving purposes, you'd want to avoid textures, and mostly avoid gradients (PNG doesn't do RLE like GIF, so I don't think vertical gradients are any better than horizontal ones, but more pixels with the same color should be more compressible). Reducing the overall color palette should help too.
It might be worth chatting with the Firefox team (f.e. Stephen Horlander) about how they compress PNGs for shipping with Firefox.
Severity: normal → enhancement
Priority: P1 → P3
Target Milestone: 1.1 → 1.2
(Pushing all open bugs to the --- milestone for the new triage system)
Target Milestone: 1.2 → ---
(Assignee)

Updated

6 years ago
Assignee: nobody → wbamberg
(Assignee)

Comment 6

6 years ago
Created attachment 624978 [details]
Removed orphaned PNGs; crushed the rest

Some of the images in the SDK were orphaned by the docs update in 1.6, and not removed. I've removed them, and gone through the rest crushing them with ImageAlpha, which reduces the size of most of them by about 60-70%, mostly by reducing the color depth.

The result reduces the size of the doc/static-files/media directory from 3290K to 825K.

It would be great to have another pair of eyes checking that the image quality still seems to be all right, but it looks fine to me.
Attachment #624978 - Flags: review?(dtownsend+bugmail)
Attachment #624978 - Flags: review?(dtownsend+bugmail) → review+

Comment 7

6 years ago
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/81a346b0acc6fdc6d9a922e82e9a0cae8b4dfdb3
Merge pull request #445 from wbamberg/662606

Bug 662606 - Screenshots bloat the SDK;r=@Mossop
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 8

6 years ago
Commit pushed to stabilization at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/62868f7590a1b5887b6c39140eed4a2994b1d10f
Merge pull request #445 from wbamberg/662606

Bug 662606 - Screenshots bloat the SDK;r=@Mossop(cherry picked from commit 81a346b0acc6fdc6d9a922e82e9a0cae8b4dfdb3)
You need to log in before you can comment on or make changes to this bug.