Closed Bug 662623 Opened 9 years ago Closed 9 years ago

After application multi-task, language selection screen is not restored resulting in no language selection and a broken user interface

Categories

(Firefox for Android Graveyard :: General, defect, P1)

ARM
Android
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 7

People

(Reporter: aaronmt, Assigned: wesj)

References

Details

(Whiteboard: [inbound])

Attachments

(3 files)

http://hg.mozilla.org/mozilla-central/rev/bfd819293f59

Testing on a green Android opt build:

http://stage.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-android/1307472764/fennec-7.0a1.en-US.eabi-arm.apk

STR:

1. Create a new profile.
2. On the language selection screen, press your device home button.
3. Open Fennec again.

ER: Back to the language selection screen.
AR: Browser skips the selection screen resulting in a messed up user interface, and no opportunity to select a language.
Flags: in-litmus?
On device rotation or tap of the awesomescreen bar, UI is restored, albeit no chance to change language unless you wipe your profile.
Severity: major → normal
Priority: -- → P1
Duplicate of this bug: 666975
Duplicate of this bug: 666979
Blocks: 666979
Attached patch PatchSplinter Review
Check for the locale picker window on startup. Show it if we can.
Assignee: nobody → wjohnston
Attachment #542274 - Flags: review?(mbrubeck)
Attachment #542274 - Flags: review?(mbrubeck) → review+
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/3d354c476890
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 7
Duplicate of this bug: 668510
VERIFIED FIXED on:

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110710 Firefox/8.0a1 Fennec/8.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.