Empty "Calendar Alarm" popup at every startup

VERIFIED FIXED in 1.0b4

Status

Calendar
Alarms
--
minor
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: tonymec, Assigned: Fallen)

Tracking

Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(2 attachments)

Created attachment 537939 [details]
screenshot

Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110606 Firefox/7.0a1 SeaMonkey/2.2a1pre ID:20110606003003
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110607 Firefox/7.0a1 SeaMonkey/2.4a1 ID:20110607003003

with the corresponding trunk nightly versions of lightning.xpi and gdata-provider.xpi

Monday I let an alarm happen after I had already left for the town; some hours later I closed SeaMonkey without having dismissed it. Since then, I see an empty "Calendar Alarm" dialog (see attachment) come up at every startup. Lightning is still functional and the mailnews window can be brought to the front.

"Dismiss all" does nothing; I can either close the popup by its top-right [X] or let it slide down under the other windows.

N.B.: with one exception, I've been experiencing crash bug 659842 at every closedown for a longer period.

-- Related with bug 367822 or bug 472961 ? All my calendars are ICS except one Google calendar (none in "Local Storage" provider format).
Since then, I get that "empty alarm" at every startup, even if a "true alarm" happened (and was properly dismissed) before the previous closedown.
(Assignee)

Comment 2

7 years ago
Confirmed, now happens regularly. I'll try to fix this asap.
Assignee: nobody → philipp
Flags: blocking-calendar1.0+
Whiteboard: [needed beta][no l10n impact]
(Assignee)

Comment 3

7 years ago
Created attachment 542104 [details] [diff] [review]
Fix - v1

This patch fixes. I'm going to check it in due to the release coming up today or at latest tomorrow morning my time, but I'd appreciate a post-checkin review. I need to take a closer look at our alarm system after the release, while debugging I found a few reasons why it might not have high performance.
Attachment #542104 - Flags: review?(matthew.mecca)
(In reply to comment #3)
> Created attachment 542104 [details] [diff] [review] [review]
> Fix - v1
> 
> This patch fixes. I'm going to check it in due to the release coming up
> today or at latest tomorrow morning my time, but I'd appreciate a
> post-checkin review. I need to take a closer look at our alarm system after
> the release, while debugging I found a few reasons why it might not have
> high performance.

Philipp: even if you fix the source I (currently) can't verify that it works, because no Lightning (trunk) nightlies since 20 June (at least not for Linux64), and all Calendar-trunk tinderboxen other than MacOSX have fallen off the page since June 22: see
http://tinderbox.mozilla.org/showbuilds.cgi?tree=CalendarTrunk&hours=36
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/linux64-xpi/?C=M;O=D
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-central/linux64-xpi-linux64/?C=M;O=D
(Assignee)

Comment 5

7 years ago
Yes, I turned off the tinderboxen so they don't collide with the release work. I'm going to produce an rc2 that contains this fix and announce it on the blog.

comm-central:

changeset:   8016:ca6d34101ba0
user:        Philipp Kewisch <mozilla@kewis.ch>
date:        Mon Jun 27 09:49:36 2011 +0200
summary:     Fix bug 662718 - Empty "Calendar Alarm" popup at every startup. pending r=mmecca


comm-miramar:

changeset:   7848:cc6c063c6b86
parent:      7843:ba76508f4bcd
user:        Philipp Kewisch <mozilla@kewis.ch>
date:        Mon Jun 27 09:49:36 2011 +0200
summary:     Fix bug 662718 - Empty "Calendar Alarm" popup at every startup. pending r=mmecca

changeset:   7851:ad38ff521c78
branch:      COMM50_20110620_RELBRANCH
parent:      7847:7471f4aa932e
user:        Philipp Kewisch <mozilla@kewis.ch>
date:        Mon Jun 27 09:49:36 2011 +0200
summary:     Fix bug 662718 - Empty "Calendar Alarm" popup at every startup. pending r=mmecca
OS: Linux → All
Hardware: x86_64 → All
Target Milestone: --- → 1.0b4
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

7 years ago
Ok, I see this patch probably hides the issue instead of fixing it, but it does a good job at it. The worst you get is an alarm sound at startup and an alarm window that opens and closes again.

Unfortunate, but thats the best we can do with this release. Maybe a good reason to release again in 6 weeks?
Comment on attachment 542104 [details] [diff] [review]
Fix - v1

I haven't been able to reproduce the issue, but codewise r=mmecca
Attachment #542104 - Flags: review?(matthew.mecca) → review+
(Assignee)

Updated

7 years ago
Blocks: 668450
Better half a fix than none at all. Philipp, if you still don't want to restart the tinderboxen, could you at least make a try-build lightning & gdata-provider pair available with this "half fix"?
(Assignee)

Comment 9

7 years ago
This fix is contained in 1.0b4
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 SeaMonkey/2.4a1 ID:20110630003039

(In reply to comment #9)
> This fix is contained in 1.0b4

Maybe, but 1.0b4 (from comm-miramar) is not compatible with my mailer: I need 1.1a1pre (from comm-central), which hasn't been built since 20 June. So to make myself clearer: if you aren't yet ready, after eleven days (and counting), to allow the Calendar comm-central builders to build again, would it be asking too much of your high generosity to make just one trunk build with the fix available as a try-build? (and I am on Linux64, but there might be other testers on other platforms whom it might interest).
(Assignee)

Updated

7 years ago
Duplicate of this bug: 669546
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110713 Firefox/8.0a1 SeaMonkey/2.5a1 ID:20110713003104

Calendar nightly dated 2011-07-13

No visible popup at startup. Not sure about the sounds because my alarm sounds are disabled.
VERIFIED based on comment #12 and of lack of sightings since the fix landed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.